Lighting problems

Thanks for having tried to help, phoboz. I really appreciate it :slight_smile:

BiosElement, please tell me if you figure out a solution.

There must be a way to fix this…

The wierdest thing is, that it happens with the official project-presets, on the official example-maps with the official tiles :confused:


Not 100% sure if the issue you are discussing is the seams between meshes or if it is something more as well (didn’t download the example map). This is the only issue I get when using something really plain and flat like the Epic arch meshes. To reduce the seams between meshes at the cost of noise you can tweak the Indirect Lighting Smoothness. Going all the way down to the min of 0.25 seems like the best option when you have very clean textures and flat surfaces with seams on them.

You can find this under Lightmass in the World Settings.

When possible it’s a good idea to try and keep flat surfaces on the same mesh and keep seams hidden between meshes. So trying to use naturally occurring seams for the lightmap seams will hide them better. An approach I plan to use is build using smaller modular pieces at first and if there are to obvious seems I’ll go in and make bigger pieces to avoid the seams if needed.

If you get to much noise but are happy about the seams you may be able to fix it by increasing the indirect lighting quality but haven’t tried. Note that that would increase the build times of course.

I don’t think it’s the same problem.

This appears to be a known issue, with a fix in-progress, but with no ETA. I think It’d be safe to ignore it for the time-being, working around where possible, but it seems like something that will get fixed fairly quickly. https://answers.unrealengine/questions/20928/lighting-problem-on-modular-floor-tiles.html

Two workarounds that work for now are either using bigger meshes for walls/floors/whatever, only changing when the texture needs changed, and setting your lighting to movable rather than statically generated. Note that this will do hell to your performance.


Alright then. Just curious how far they are with this patch :confused:

Thanks for the info!

hey, guys

Had same stupid problem, spend whole day to fix it. The problem is in indirect lightning, try setting Num Indirect Lightning Bounces to 0, it is the only thing that worked for me.

That a brute force way to fix it for sure. :slight_smile:

The problem there is you lose any GI that would be baked by lightmass.

I’ve not had a chance to finalize the troubleshooting guide with shadow seams caused by Indirect Lighting bounces yet but it’s very close!

In your world settings you can adjust the Indirect Lighting Quality and Smoothness to get better results. Try 2 and 0.6, respectively.

You can follow any updates here: https://wiki.unrealengine/LightingTroubleshootingGuide

yeap, very bruteforce, but worked for my needs) Also I have almost got rid of seams with :

  • static lighting level scale 0.5
  • indirect lightning quality 2.0
  • indirect lightning smoothness 0.5
    but I think this parameters are very special for different cases

I’ve discovered the problem, its the light map resolution of your mesh / object.

If you select the object you created, in the details, go to Lighting, then, in the Overridden Light Map Res, try to 128, 256 or 512 and rebuild all, you will see the strange lighting disappears.

Now I’ll need a Blender tutorial to do it directly to my 3D models, so the Unreal Engine 4 won’t have to do it in every object.

hello everybody I’m new and have a problem.

Somehow when I start a new project I don’t have any light on the “lit” view mode. Only on all the others.

I see all the actors but it seems like their lighting is not working. And I didn’t changed any settings.

Hope you can help me. Thanks in advance.

Did you build your lighting?