Lighting objects with emissive material

Hi!. I’m having some trouble with getting objects lighted from a emissive material. I’m developing a level that simulates the solar system. The emissive material is the sun but the light does not iluminate any of the planets. I’ve tried a lot of things and I think it might be caused by the distance between them, about 149000000 uu, that atenuates the light intensity. Do you have any ideas?.

Thank you so much for the help.

For starters, emissive materials will only generate actual lighting in UE4 when baking static lights and the actors they are used in have “use emissive for static lighting” enabled. I assume your solar system has moving planets, so they cannot use static lighting.

Also, if you are using such massive numbers you will have visual glitches caused by the limits of 32-bit floating point precision. Light values would also need to be enormous to realistically decay at such distances and shaders also have precision limits. Try to scale everything down by a constant factor to get things into a manageable number range.

There’s no reason you should use emissive for lighting when a point light will work instead. Put a point light in the middle of the sun and turn off cast shadows on the model itself.

Using emissive material to light your scene is not an ideal way for what you are trying to achieve and it is used for static lighting and is costly once you start to make a super clean image.
However, select your mesh and Tick ON “Use Emissive for static Lighting” and give it a crazy value, better to try on a test scene to get a hang of it