Download

Lighting not the same while in edit mode versus play mode.

Hi everyone,

I’m currently having a problem where my edit mode lighting is considerably darker than my play mode lighting. Here’s a picture to better explain what I mean:

558af9e64354b55a52a70421bc5e4d7e454fd6f1.jpeg

I have no idea where this might be coming from. I’ve been doing quite a lot of research and I’ve been tinkering with the cameras and post-effects to try to fix this. If you have any idea as to where this might be coming from and need anything from my set-up, please let me know. I’ll keep an eye on this thread to answer as soon as possible.

I’m using Unreal 4.7.6

Thanks guys :slight_smile:

EDIT: And this is the part where I realize that I am stupid. Turns out that after baking the lighting, both viewports updated themselves to fit with the right colors. The problem was that my Skylight was too strong and only showed when I was playing.

Watch the onscreen messages when you hit ‘play’. You’ll notice that UE4 ‘builds lighting’ each time before you play. You need to make sure your editor is set to render in game mode otherwise … YEAH - the lighting is different when you play. This can be VERY taxing on your system though.

@kennyrosenyc where can I find this setting?

To build lighting click on the “Build” button on the top toolbar, and select either Build All or Build Lighting Only to build the lighting.

If you don’t want to have to do this, you can set your lights to “Movable” instead of static or stationary. Doing this will make them Dynamic lights, and will look the same both in game and in editor. If you are going to use a lot of lights then dynamic lights are not the way to go as they are more performance hungry, but if you are just using a sun light and a sky light dynamic is the way to go.

Here’s some more info on the different lighting techniques:

Hope that helps!

" Doing this will make them Dynamic lights, and will look the same both in game and in editor. ", sorry for late post but this not being same in game as in editor is the deah of realism :slight_smile:
Using now 4.23 , any other issues that would cause this ? I would use static, more performant BUT as always I’m stuck atm with just myself doing dev,so static is OUT of the question,large and getting larger 2x2 tile setup, all my own.

Lighting Only Pic attached, shadows on right near camera, not being seen in game.
Btw, yes, all my lights are dynmaic,scene too complex for static given hardware and no no access to render farm .

Thx

Hi , I applied same setting as you guys mentioned but still my scene looks different before and after light build… don’t understand why… if it’s hardware problem ,please mention that too… i am using gtx750 with i5 760 first gen and 12 GB RAM only. Light build is taking almost 1 hr. for this small scene. Please help me out.

first image is in viewport, second image after light build

I know this is 2 yrs since BUT we must make sure peoiple aren’t getting old/bad info:

You said Doing this will make them Dynamic lights, and will look the same both in game and in editor., but my experience NOW in 4.24.3 is NOT that.

No one seems to have any idea why, this is the most unanswered question it seems, tho the most needed. (lighting is everything)

So anyone ?