Download

Lighting/Lightmass, Weird Highlights & shadows, no problem with lightmaps.

So I’ve come across an interesting problem, I’ve been creating these modular wall panels with little bevels and lines going through the geometry/static meshes, Now because the Tri count is low and to save time I thought there is no need to bake normal maps

But I’m getting these weird Shadows and Highlights on my Meshes after baking lights. Here is an example:

1dcbb47012f3c421826dab391b42ab15d291cde9.jpeg

As you can see when the lights hits the panels well it works as intended but when it’s dark the panels start to mess up, it happens with my other panels too. I’ve tried various settings and tweaks.

It seems like Lightmass has trouble calculating baked lights based on the geometry.

Some points:

• Baking Normals to a simplified mesh fixes the issue completely (but what if I don’t want to use normals, they are not necessarily needed here and geometry vs normal map is a better trade-off here).

• Work’s perfectly with Dynamic lights, I love dynamic lights… no BS what you see is what you get. However I need Static lights for now.

• Lightmaps play no role here, Changed lightmaps UVs many times, set up correct index, uping the resolution, makes no difference in fixing the problem above. Turning Full Precision UVs makes no difference either.

• Some Panels literally fix themselves if I rotate them 180 degrees round (not the one in the screenshot) and use the other side which is exactly the same, Looking at the geometry in 3ds max everything is fine, both sides UV’s are unwrapped separately for lightmaps, No errors on fbx export or import, I really don’t get it.

• Light baked at “Production” Quality.

Any Ideas or thoughts, I’m obviously doing something wrong.

Bump, still looking for any thoughts on why this is happening.

It’s hard to tell without the geometry there. What modeler do you use? Do you “split normals” or “split vertices” when exporting?
What resolution have you configured on the objects? Are the panels separate objects, or one solid mesh?
Can you post a wireframe screen shot? How about a screen shot from the “visualize deferred passes” mode?

Heres the settings and Info:

3Ds max is the software.

It’s one full mesh with welded vertices and no seperate parts, see wireframes below.

I don’t think it’s the light map, I made various lightmaps including full splits, tried UE4 auto generated lightmaps, resolutions: 64,128,256, No difference, some cases I had worse light bakes (as expected).

613e69c4d086cc7fbbdd9b6827753fcc8d4a8406.jpeg

Hi blaz3d, lets try this in 3ds max go to your material editor and select the material that is assigned to the model in the material settings select 2 sided material its under Shader Basic Parameters tab. Next select your model go to your modify tab select element mode to select all the faces, now go to your polygon: Smoothing groups tab and select Autosmooth this will automatically select the correct smoothing groups for the faces. Try to export you FBX model again and lets see if this helped.

2 more things came to mind add an Normal modifier to the model and export the fbx and then lastly in Unreal Editor open the material in the material editor select two sided for the material and build your lighting again.

Ok hope it helped holding thumbs! :wink:

My best guess is that it’s a lightmap resolution problem, that the pixels are too big and it’s bleeding lit parts over to other areas. The lightmap UV looks fine though, the main issue could be if the pixels are bigger than those cracks.

I managed to fix it! :smiley:

I am so silly.

I assumed “Min Lightmap Resolution” would over ride any lightmap resolution.

I assumed “Source Lightmap Index” was “Light Map Coordinate Index.”

Looking at an another example mesh I realise “Source Lightmap Index” should = 0, and “Light Map Coordinate Index” should = 1

Set “Min Lightmap Resolution” to 64

Set “Light Map Resolution” to 128

All is working good now :slight_smile:

These parameter settings have too much of a similar name to each other!

Awesome glad you sorted it!