Download

Lighting Issue when 'Distance Field Shadows' enabled...

Hi Guys,

Having an unusual issue when I’m setting my direct light to use Ray Traced Distance Field Shadows.

It’s behaving as if my mesh is not double sided. See: http://i.imgur.com/yVYSuQ1.jpg

However, when I deselect and make no other changes, I get the correct lighting solution. See: http://i.imgur.com/70OUBNS.jpg

What I’m trying to achieve is the soft shadows we all saw on the Paris Apartment demo, without having to split every wall & enter a high light map resolution.

Any ideas?

I’ve not used the Unreal Paris Apartment demo that was released, but I’m fairly certain that it used static lighting and not dynamic. I could be wrong though.

Can you post a screenshot of your light source settings? When you take the screenshot select the eye next to the search bar in the details panel and click “Show Only Modified Properties.” This will condense the list to make it easier to read what has changed.

Also a screenshot from outside your room with the Viewport > Show > Visualize > Mesh Distance Fields could be helpful as well. This will allow us to see the Distance Field Volume that is generated for your mesh.

Thanks!

It looked as though he had some spot lights from the windows and I suspect he used that shadow method given the soft shadows. That’s my best guess anyway.

Light Settings here: http://i.imgur.com/C4XQ4Mi.jpg

Mesh Distance fields here: http://i.imgur.com/btZYWrU.jpg

Also not that with the mesh distance fields, I’ve increased the resolution to 100. I know the resolution is way off which I assume is the problem.

P.S. When are you going to add plane lights??!? :slight_smile:

I’m pretty sure Benoit used static lighting for Unreal Paris. It’s currently the only way to get very precise shadows required for architectural visualisation. Download the berlin flat demo project in the marketplace you’ll have a good place to start for interior lighting!!! It’s based on Koola’s method.

Hmm… I’ve seen all of them, but I was trying to avoid chopping up the walls to smaller meshes & giving them higher lightmap resolution…

I was hoping to achieve a similar effect via DFS.

In any case, I’ll wait to hear from Tim given it’s an unusual issue I would like resolved.

With Distance Fields, you would not want to use large meshes like this. They work best with more modular mid-sized pieces. Daniel posted some really helpful information about DFs with regards to memory usage with volume textures that are generated. Ray traced soft shadows , Situation (Problem) - Rendering - Unreal Engine Forums

By breaking the mesh into smaller pieces you will get better distance field resolutions without the need to use anything close to a resolution of 100. Also, if you decided to use lightmaps with bake lighting vs dynamic you would not need drastically high lightmap resolutions either.

Pre-computed lighting will give you the best results even though it does require more work to set up the lightmaps and meshes.