Download

Lighting is messed up

guys why is this happening?

Have you tried getting rid of the errors?..

yes, it had no effect.

You’re using static lighting, I’m guessing?

idk, i got this level from marketplace

I’m pretty sure it’s a static lighting bug. You can change all the lights to movable, that should fix it.

Hi!

It’s just the quality settings!! Either you’re building light in preview or your indirect lighting quality under lightmass is too low!!

In my experience noise in light bakes usually means lightmass is having trouble finding the light source. Since it looks like this scene is using natural light I’m guessing you probably need to put lightmass portals near the windows.

It’s probably cause you build the scene with preview quality, instead of production.

building it with high quality takes ages to complete.

Yup, but no other choice here if you want to have good lighting

It’s a combination of too low lightmass quality settings, too high lightmass resolution on certain meshes (that’s why it takes so long) and lighting scenario unfavorable for lightmass (probably small openings for skylight to go through and no artificial light sources inside the interior).

  1. Switch your viewport to lightmap density mode, and review lightmap resolution of all the meshes in your level. Ideally, everything should have cyan color (between green and blue)

  2. Once that is done, and your bake times aren’t out of control, increase lightmass quality preset to at least high.

  3. Make sure you have lightmass importance volume in your level roughly covering your level, but not much larger.

  4. Add Lightmass portals in the light openings to make lightmass’ job easier.
    Lightmass Portals | Unreal Engine Documentation