Lighting inside a house is dark

Hi,

I am trying to build an inside of a house. For some reason, the lighting is not satisfactory. The problem is that even though I have added enough amount of lights, the scene is dark at first, but become brighter after a few seconds. I doubt if there’s any method that makes the scene bright at first look, and the light not change over time. I used no spot lights inside my house and I have set up 5 box reflection and 2 sky lights. One of my box reflections surrounds my whole house, and other four surround four different bedrooms of my house. One sky light is outside, and one sky light is inside. I also used two lightmass volume, with one surrounding my house, and the other surrounding one of my bedrooms.

Also, I need a lot of point lights to represent the real-life lightbulbs so I make them static. But all the examples I’ve seen use stationary lights. Is it correct to use static here?

Last, the directional light is supposed to be the sunlight, but I have shadows due to it inside the house. How can I block its effects when I am inside?

I am new to UE 4 and don’t quite understand about the lighting and rendering parts. I have read them on the tutorial manual, but I want more specific explanations. It’s best if there’s some videos about that.

Thanks!

Chenglin

Hello wcl1993,

It sounds like you have several questions and issues rolled into one thread.

First, to address the issue of the scene starting dark and then becoming brighter over time, this is a feature in UE4 called Eye Adaptation. Eye Adaptation, or automatic exposure, causes the exposure of the scene to automatically adjust to recreate the effect experienced as human eyes adjust when going from a bright environment into a dark environment or vice versa. You can either disable this feature completely by, in your viewport, going to Show > Post Processing > Eye Adaptation.

This disables your Eye Adaptation completely and will still be present if you play/launch.

The other method is by going to your Project Settings > Rendering > Default Postprocessing Settings and uncheck the box next to Auto Exposure.

Both of these methods will disable eye adaptation and will not allow for a change in light. However, this does diminish the realism of your scene. If you want a slight amount of auto exposure I recommend using a post processing volume. Within this volume you have many options that influence post effects on the last pass of your render. There is a section in the volume called Auto Exposure. You will need to go to the volumes Details Panel > Post Process Volume > Settings > Auto Exposure. There you will find tabs for Min and Max Brightness. Setting them both to 1.0 will effectively neutralize the effect. However you can set in the Max how high and the min how low you would like the brightness in your scene to be. The difference between the two will determine the difference between how dark and light the scene will be and how far the scene will brighten.

Secondly, the difference between static and stationary lighting depends on how the light is calculated. Static is completely baked shadows. This allows for very dark shadows almost completely black in places. Stationary is baked as well but has elements of movable/dynamic shadows and allows for both static and stationary lighting and shadows. These shadows will be a bit lighter and allow for that soft colorization of your shadows and are ideal if you want more realism but don’t want these lights to move. These lights are more expensive for your scene and will lower FPS. If you optimize your lighting then this isn’t a major issue as they do not increase the call a great deal unless you are using dynamic shadows and lighting. For this you will need to determine between the two to decide what is best.

The directional light will always cast some shadows on your house. For instance when sunlight is shining in through a window it will cast shadows around the areas where the light is not influencing this. There is a number of things you can do in order to adjust how much the light influences the shadows in your house. You can adjust the distance the distance from the camera you can see your shadows. This is done by going to your shadows in the lights details panels and adjusting the Shadow Distance. You can turn off shadows completely and use another light to case your shadows outside like your SkyLight.

I am linking you to our lighting troubleshoot and documentation. If you get lost please use this as reference.

If you have any further questions or you get lost please feel free to post again.

Logan

Thank you for your detailed explanation, Logan! I have been trying different lights and found that just a stationary point light will be enough in my house. And as you suggested, I turned off the Eye Adaption choice and feel better now. I don’t quite find Eye Adaption useful since in almost all the games I have played, no scenes seem to be very dark at first and then become brighter.

In addition, I found that the lighting and light bulbs usually don’t “correlate” that well, meaning that sometimes I could see the shadow casted by my character, but I can’t see the light bulb as it should be there. And sometimes when I come close to fire, I see no shadow casted by it. I think this is quite interesting.

Again, thank you for the kind response!
Chenglin