Lighting Inconsistent between BSP and Static Mesh

I have created a series of meshes from BSP in order to improve performance and improve workflow. The problem is that the lighting is looks completely different for the Static meshes then it did for BSP . There are no error messages when I re build the lighting so I am not sure why it looks so different ( previously there was a problem where the UVs did not line up properly which has been fixed)

I made a example level with a point light and you can see the difference . In the first image the shadows for the point light are turned off and the lighting is consistent.

In the second image , cast shadows is turned on for the point light and the static mesh is completely black.

If I change the UV settings in the static mesh using the settings show below the lighting will be consistent , but the textures will not line up . If I use a different UV Channel it does not appear to have an effect.

How it looks with the new static mesh settings.

Are there settings I could use to get the lighting consistent?

Is there something I may have missed when exporting the meshes?

Or is there a way to change the scale and position of a material on a static mesh , similar to how you can with BSP?

Any information is useful here .

Thanks

Edit

If the meshes mobility settings for the are set to movable , then it looks better than before , but still not the same as a BSP surface.

Hi,

Thank you for your report. I was able to reproduce this issue in our main branch as well as Beta 6 very easily with the information you have provided. I have entered a report and assigned it to our developers, including your note about mobility.

is there a way to change the scale and position of a material on a static mesh , similar to how you can with BSP?

Until this can be resolved, you may want to go into the Material and use TextureCoordinates to reshape the UV of your texture sample node to better fit on the mesh.

Thank you,

Alexnader

This looks like a pretty straightforward case of lightmapping coordinates being bad.
The reason ti’s black in the top image is because of the unbuilt or badly built lighting. Rocket will display unbuilt static meshes with dynamic lighting in the editor, but will render them black in the game as you’ve seen.

The reason your texture tiling gets messed up after applying new lightmapping coordinates is because you’re modifying channel 0, which is , by default, the channel that your diffuse texture uses, causing ti to tile, but giving you nice looking lighting once baked.

Using Rocket to create your lightmaps is really a last resort as it’s almost always better to create them in your modelling package. there’s a TON of info out there about creating lightmaps for UDK and those principles hold true for rocket as well:
https://www.google.com/search?q=UDK+lightmapping+tutorial

Edit: I apologize for not fully understanding the question posed and assumed the meshes were imported rather than being made from a BSP. I can see how this is definitely a bug/issue. honestly, i wasn’t even aware that you could create a static mesh from a BSP! That’s a great thing to know.

#A Bug When Making Static Mesh From BSP

Dear Toxic Games and Alexander Paschall,

(I am writing this after reading your response, Alexander)

I’ve noticed that when I make static meshes from BSP,

the lighting model does not get build correctly.

There is an easy fix though!

(it is still a bug tho)

You go into the new static mesh properties

and click on this

you only click on use full precision so that the “apply changes” button lights up

you can uncheck it after that


once you click "apply changes"


the lighting model gets fully build

#Bug Resolution

Have a BSP turned into a static mesh do whatever “apply changes”, does at the time of its creation

:slight_smile:

Rama

PS: this is what worked for me anyways, please try my solution and let me know, preferrably with a static mesh that was just created from BSP