Download

lighting errors on modiular Components

I’m having a bit of an error with lighting in this engine. Specifically when it comes to using old school modular techniques. For example see picture this is just a table where I modeled half of it then. Just mirrored a duplicate. The seams are aligned perfectly but I still get this weird shadow.
f97bfd36b8197407ef9cb3d8a2c1a2e1c80f2c27.jpeg
In this example the model has overlapping UV’s. Which UDK has never had an issue with, but in this version the shadows are overlapping as well. There has to be a way for the shadows to ignore the UV’s like in UDK. Otherwise in this aspect this game engine would be less efficient.
64e6eb5d1cb1facde74bc17445ba78c817b00e54.jpeg
Finally working with glass is a huge headache, I must admit it looks much better. However I can’t see it in the content browser and I have to put it in the level and bake the lighting to truly see what it looks like. See example of the lighting error that I had the lighting in both areas are connected to the same piece with another piece just on top of it. However one part of it is all dark and the other is all light, not accurate to the actual shadows in the scene.

Either just use dynamic lightning (then you don’t have to rebuild the light) or create a 2nd uv channel in your 3d program: https://www.youtube.com/watch?v=z5yc-bKbHyc

Wait but won’t having 2 UV channels make things less efficient. How did UDK do this without overlapping shadows. Any idea on how to make 2 UV channels in 3ds max, never used blender before.

Also I can’t use dynamic lighting because it makes all the glass in my scene look too dark.

Thank you for your quick response

you can also make a second uv channel in UE… find the asset in the browser, open it. In window or view(something like that) theres an option that mentions UV’s make sure its on, then on the right at the bottom theres a button for create uv. If you cant find it ill load up the engine and find out exactly what the options are

also if your getting a warning of overlapping uvs then make sure when you do your unwrap that no lines are touching at all… no pieces of any part of the mesh can overlap on the UV

But this doesn’t work with all meshes :slight_smile: That’s why I personally do it in my 3d program

Hi VisceralD,

There are a few links that will get you started in developing your assets with a 2nd UV channel and proper lightmapping techniques.

World of Level Design: Lightmapping Basics

3Ds Max Creating a 2nd UV Channel
Creating Modular Assets UE documentation

Also, using a second uv channel is not going to be as performance intensive as using dynamic lighting that is casting shadows on all your objects in your scene.

I hope this helps!

If you have any other questions feel free to ask!

Thanks!
Tim

Looks like the main issue though is a low resolution lightmap, the pixels are very big so they’re overlapping on the UV’s

While upping the lightmap resolution would help in most cases, if you have overlapping UVs the shadows will still appear on the overlapped UV islands. They would just be cleaner and no so blobby. :slight_smile:

Tim