Download

Lighting dynamic players when using static lighting?

I have a parking lot modelled which has street lights scattered about for lighting. The lights are spot lights which are set to static. The map geometry is static meshes and landscape. The problem is that the player remains dark when walking under the lights. Setting the lights to stationary fixes the dark player problem, but then you get the light overlap errors. Going full dynamic fixes this, but the lighting is not nearly as nice as produced from compiled lighting. Is this a way to get all this to work?

Can you post some screenshots? Your player’s lighting should be updated using the Indirect Lighting Cache samples, which are distributed throughout the map. Increasing the number of these samples might fix your problem, but it won’t look as good as just using stationary lights. I would try to reduce the scale/size of the stationary lights so that they’re not overlapping.

I think I see the problem, but I’m not sure how to fix it. The problem is that there is no Lighting Cache over the portions that are landscape, even though the area of landscape is inside the Lightmass Importance Volume. Is there a switch to turn this on?

Static lighting will look really bad even if you had the indirect lighting samples since they only provide indirect light. You need to use stationary lighting if you want proper look. Turn off shadow casting on less noticeable lights to help with the overlapping, or try to spread them out a bit.

Found it: Enabling static shadows on the landscape also enables the indirect light cache over the landscape.

There is an indirect character lighting volume you can place around important areas of your scene. Areas outside the volume will have much lower resolution probes, or will default to sky light only.