Download

Lighting Compilation taking forever

I am learning Unreal, currently using 4.7.2
I am making a very simple scene, a room with a door and a tree I downloaded from www.themantissa.com

This is the scene:

It has a single point light, and that’s it
And it’s taking forever to compile the lighting, and I have no idea why? I tried hiding every other light, even hiding the tree so it’s just a closed room, but no luck - it just hangs on 95%.
Any ideas why? =(

-add a lightmass importance volume
-which lightmap resolution do you use?
-could you post your PC specs?
-in the systray do a double click onto swarm - check if something is moving in the window :slight_smile:

Hi, I will check these things.
Don’t think my specs are the problem, I have an I7, 8GB Ram DDR3 and a SSD. More importantly, I just compiled the Realistic Rendering example from the Learn section without problems, and this has much more complex lighting.
I don’t even know what’s a lightmass and lightmap, I will go learn what those are and try to understand it to see if that’s causing the problem.
Thanks

lightmass importance volume: you can set the area which should have the best light quality. This will reduce the build time, because it wont build the part that are outside of the volume in a high quality :slight_smile:
lightmap: http://www.worldofleveldesign.com/categories/udk/udk-lightmaps-01-basics-and-important-principles-for-creating-using-lightmaps.php

I added lightmass importance volume, no effect.
My lightmap is low, at 64

It gets stuck forever at “process mappings” on Swarm, I don’t know what that means?
I downloaded your foliage kit and tried to compile it, same thing - it’s at 35% and its been compiling for over half an hour. Yes, I did set illumination quality to preview.

EDIT: and when it hit 100% compiled, Unreal crashed. oh god why…

I have the same problem when i try to import some Fbx Mesh, and i try to change this mesh with another Mesh from Market Place this work ok. i think this problem from your mesh, not for lighting setup or lightmass.

Agree on that I build a fairly big scene from my home town just to test the engine and light build takes less than 5 minutes i build bsp brushes in the editor and imported some self made fbx meshes from blender.

Looks like you might have BP_sky_sphere in your scene this renders nice clouds but takes for ever and your inside a building so you dont really need that try disable that!

Scale nearly 1.1 as close as possible ± 2 square KM.

Used google maps screenshot as reference my city live there all my life.

Photo taken from my bedroom window.

http://s15.postimg.org/jynnkaydz/1888642_1429839043926573_21948699_n.jpg

In game screenshot (W.I.P)

http://s21.postimg.org/tno5v88v7/Capture1.jpg

Take a look at the lightmass importance volume some area’s are excludes.

http://s11.postimg.org/xhqzi3qlr/Capture.jpg

Greetings,

For those that are having the same problem, like I was, there are some Troubleshooting you can do. In my case it worked. Try to create a new clean project and importing the level from the other project. (just migrate the level and everything will come with it). Other things you could do is saving the level and deleting the landscape and sky box if you have it. (then click build to see if gets faster).You can also delete and bring a new Lightmass Importance Volume.
In my case the landscape was the problem, It was taking 15 hours to build, I deleted it and brought a new one and it just toke 45 minutes to build. Hopefully you landscape is not the problem, in case it is a complex one.

Good luck to you!

This thread was more than 1 year old and was done with version 4.7. I’m pretty sure it has been sorted out by now :slight_smile: