Download

Lighting Build Failed

Hello,
I recently rebuilt a machine, and i haven’t been able to get light to build. first i tested launcher versions of 4.22 and 4.23 but i couldn’t get lightmass to build. then i installed the 4.24 source version of the engine, and manually built unrealLightmass in the solution, and that solution compiled fine, but when running a clean project, the lighting would still not build.
other things i have troubleshooted based on forums searches:
> tried running light build with windows defender mostly disabled (realtime disabled, firewall off, allowed apps in list if firewall is on)
> checked to make sure multiple instances of swarm aren’t running
>cleared cache and validated through swarm
>tried alternate directories for the cache
>updated video drivers with updated directx as that is integrated into windows updates now
>16Gb of RAM on machine, and just testing on a clean project, so i don’t think memory is an issue
none of these solutions led to a successful lighting build.
the one error i do get in the swarm agent log is:


[Interface:OpenJob] Error: Invalid class

i have no clue what class this is referring to, but this is the error i got when testing on three different engine builds.
are there any other things i may be overlooking?

[RESOLVED] I re-installed windows, and consequently re-installed the engine as well, and now everything works. unfortunately I have to repopulate the machine with all of the production software again, but happy to have lightmass working.

I build the ue4.24.3 from the github source code with the Development Editor option .I have the same problem and compile the
UnrealLightmass.It works.