Lighting build dark ONLY in ES2

Using 4.15.2… no, this is not a lightmap issue; the problem only occurs in ES2, not SM5. What I don’t understand is why it was working fine up until a short while ago. Now if I build lighting in ES2 it comes out dark. I have a single directional light set to stationary, and a skylight set to static.

When I crank the directional light to 20, it has a slight effect of brightening the mesh, but it doesn’t completely blow it out like the other objects in the scene (the cube for example). It’s as if the lighting is being filtered through something, only for the large static mesh “landscape”.

I think I might have triggered a bug in the engine, as this seemed to happen shortly after I had toggled the lighting channel 0 off and on. All objects (including the lights, are set to 0). The “landscape” static mesh has collision set to complex. Any help would be greatly appreciated… I literally am out of ideas how to fix this. Thanks so much!!

-Adam

Well it keeps on forcing a dark build in ES2. No explanation why… even though I’ve tried many different things, including deleting and re-importing the mesh, a different mesh,deleting the lights, and force no pre-computed lighting. The only thing left to try (unless someone has a suggestion) is to migrate all assets to a brand new project. When I tried just the landscape mesh in a new project, it behaved normally. But for some reason, this original project refuses to right itself.

Here’s a better view of the problem:

Two different projects, same lighting and same light mass importance volume, in the same physical positions.

The bad one is called LQ_Lightmap_0_1, and the good one is LQ_Lightmap_1_1 for some reason; shown below:

So something is affecting the lightmaps…

Hey AJ,

I didn’t experience the same Lightmap issues with my test assets. Since there could be a lot of things at play here I think it will save a lot of time if you were to provide a small sample project with just the colorful “landscape” static mesh in the scene with the incorrect lighting.

Thanks!

Ed

Hi Ed, thanks so much for your reply! I have condensed the project down to just the mesh and added it to a 1.2 MB .zip file. Can I private message you with the file? The mesh will be used in a game, so I don’t want it publicly available. Thanks!

Well, I migrated my assets to a new project and everything works fine. :slight_smile: It still would be nice to know what went wrong in the other project, though, to avoid repeating the same issue.

https://forums.unrealengine.com/member.php?484739-Ed-Burgess

Feel free to pm my forum account. I’m going to mark this post as resolved for the time being since your issue no longer occurs. If I have time to look at your project I will update this post with more information.

Thanks Ed! I sent you a PM. Have a great weekend.

-Adam