Download

lighting and texturing landscape

Hi all,

I’m trying to texture and light my landscape properly. I created this texture on Worldmachine software and i put it on a material which i applied to my landscape.

0606b613d450a157c8a9facd04125a146031a026.jpeg

The problem is that, as you can see the render is far too bright :

82558d1d8709024b71beb39bbf1edaa254f96091.jpeg
269a19507e9589940632649d3a73433fac2f1c46.jpeg
do i have to change the lighting ? Or do i have to adjust some material properties ?

I have also another issue about the lighting : i cant build lighting with light mass importance volume component. Why so ?

Thanks for your help

  1. just scale down the texture with the landscape coord :slight_smile:
  2. what happens when you build the light? -> do you get any warnings/errors?
  3. put the quality settings of your editor to “epic” (sometimes low quality settings lead to problems → landscape collision,…)

hi figther5347,

Thanks for quick reply.

  1. My texture has the very same size as my landscape (2017 x 2017). I rendered with a much lower brightness on my texture in order to counter the over brightness render and it was clear that it was fitting perfectly.

  2. Building lighting process remains stuck at 0% endlessly

  3. Thanks ! :slight_smile: it improved a lot the render not only in terme of quality but also in term of brightness as you cans see :

3dcadd276a14336e2ff53e1abc8f1ea4d089aed7.jpeg

  1. you could turn down the brightness of your texture in the texture properties. Also check your “auto exposure/eye adaption” settings -> there you can choose how bright the level should get over time
  2. open “swarm” (you can see it in the systray) and check if something is moving -> sometimes it can take a while till it builds the light (but make sure that the lightmass importance volume just covers the parts which should get good lightning) :slight_smile:

hi Fighter5347,

  1. I didn’t find auto “exposure/eye adaption”, i just found a eye adaption flag here :

5.jpg

I switched it off, but i didn’t notice any change in the render
Where can i find “auto exposure/eye adaption” settings please ?

2.i looked for swarm agent, but didn’t manage to find it. Where is it please ? I just read that the swarm agent is launched whenever you build lighting but i only see this :

6.jpg

Thanks

  1. eye adaption -> post process volume (when you dont have one, just add one -> you can find it in the volume tab) :slight_smile:
  2. you can also adjust the brightness of your texture in the texture properties
  3. swarm:

swarm.jpg

fighter5347,

swarm showed it was moving, so the process wasn’t “frozen”, and it was very slow but the lighting was built. However i have some lighting issues as you can see here (notice that i strongly reduced the brightness of my texture) :

9619a67f6f15595fb77654a3e3e5015621808b89.jpeg

edc9b3496dbe9984c432b7b9a892ed7ed1df4717.jpeg

Why so ?

he here is how i scaled the 2 boxes, maybe i did something wrong

31f1a90ea72a323fef3504da9b6883532489ebd4.jpeg

  1. disable specular in your material -> on a landscape the default values looks really bad ^^
  2. Normally you just have to increase the lightmap resolution of your landscape

thank you so much fighter5347 ! :slight_smile:

I’m applying your nice tips

i’ll reply you very soon

Ok i disabled specular in material editor and it looks much better now.

About increasing the lightmap resolution of my landscape, should i edit it here ?

9cb35c687f72a4ee62d0839bf486e167e9825915.jpeg

Or there ?

9f27e5a6912059801878876ea275da98e7b3492b.jpeg

I’m asking because it’s very time consumming in term of building the lighting

Change it in the properties of the landscape -> 2nd picture. Try a value of around 2-4

Thanks again. I changed it, building the lighting took an hour and the result is not worth the time spent. So i will refine static lighting at the very end of the creation process.