Download

Lightbleed in Corners after Build

Hay guys im having problems with some light bleeding in the corners of rooms after I build lighting. I have gone over the lightmapping several times and the results are pretty much the same each time I alter the light map. I made sure that the Lightmap snaps to the corresponding grid size (128 / 256) in maya. Furthermore I have messed with the world Lightmass smoothing and other options. I have checked online and seen people say that walls should have a thickness to them to prevent lightbleed, and match up exactly in all the corners. My walls do match up exactly in the corners but have no backface/ thickness to them. How would you guys sort this problem out if this happened to you? I have upped the resolution and this sorts it out to some degree but I dont really see it as a fix. I have also thought about placing a volume around the outside of the walls to stop the directional light hitting it but dont reall see that as a proper fix.

Its strange because some parts are completely fine whereas others show a little bit of bleed as shown in the below image. The top two images (of the first image) show the outside of the building whereas the bottom shows the lightbleed, finally the second image shows the lightmap made in Maya

EDIT: I have tried changing the directional lighting from stationary to Static, and even moveable but no luck
64476284502e81725395dd62b74438185f05c077.jpeg

fbc643df41184a75958733974222ca1eb4de2ed5.png

It still looks like UV lightmap bleeding to me, because of the way your UVs look I’m guessing you would need extremely high resolution on your lightmap for this to work. The light information from the pieces on the outside are bleeding on to your pieces from the inside. I would recommend splitting the interior pieces and the exterior pieces into different meshes. Or break the sweep into smaller lengths so you can have more lightmap room. I don’t know what else it could be.

I’m struggling with this too on my project.

I think that’s directional light dynamic shadow bleeding. For me, it bleeds through whenever walls/ceiling are less than 1 meter thick. (100 uu). Shadow bias and shadow cascade settings might help you, though for me (with a long hall) it doesn’t help. The only way around it that I’ve been able to find is to layer shadow casting meshes around the exterior corners that disappear when you step outside.

Hopefully there’s a better way, maybe someone else will have the magic bullet! Light bleeding is a big problem that can be really hard to work around in ue4.

Where is the epic games support staff on this topic? How can it be such an issue with meshes??? There needs to be a proper procedure for eliminating this BUG! Honestly Ive been dealing with this issue for far too long with no real response on how to fix… They say, to reduce light map bleeding, “try” these steps, but ive tried numerous times and approaches from many tutorials with zero consistency! 0 reliable results. Epic, Can you please respond to this??