Lightbaking issue

I’m having the weird issue where, whenever I add one mesh to the level from now on (doesn’t matter what mesh, I tried multiple),
my next lightbake is suddenly much darker then before (without changing anything light-related, only adding the one mesh).
After I delete the mesh again, and rebake, the lighting looks normal again… Pictures for illustration:

I had this in 4.11 already and upgraded to 4.12 today, but the problem persists.
Any suggestions? This has been bugging me for days…

Tried lowering some lightmap resolutions. Tried adding just more than one mesh. Still, same issue… Anyone an idea?

Are you sure you’re building with the same lightmass quality level? My guess is that the first might be at maybe medium or high and then when you update it’s building at draft

Thanks for your answer. I’m absolutely sure I’m using the same settings though… (Lightmass settings on high) Double checked

Copied all the objects to another empty level. Same issue

Tried changing quality setting to production… Still, the bake is much darker after new meshes are added…

I miss good old times of q3map2 lightmap baker for Quake 3 - it was slow, not as pretty as Lightmass, but 100% predictable and consistent.

how about the light map UV set ? have you checked that as well ? when you bake your light map are there some warnings ?

for me your second image seems to have some light map issue.