Light Without Shadows


Edit: “viewmode unlit” achieves my desired effect, but I do not know how to have it always enabled.

I have been looking everywhere for a lighting tutorial to help me with this, but have failed to find anything to help me.

Basically, I want a method of lighting my game and maps that creates no shadows, but isn’t pitch black.
The reasons being, for the project I wish to create I want the game to be very visually clear, and removing shadows also would put less strain on computers.

If I’m not being clear, I’d like to reference the Light Amplification Visor from Ultimate Doom / Doom II / Final Doom (old games). I want their effect, but always enabled.
No shadows, no dark spots, no bright spots, just uninterrupted visual clarity.

Please, if anyone has a guide (preferably video), let me know. I’ve been avoiding tackling this issue for months because I can never find the solution.

Point Lights | Unreal Engine Documentation “Casts Shadows”

I’m not sure if you misunderstood what I was asking, or you just chose not to elaborate.

I want my game to be globally lit, with no shadows, uniform light intensity, and be unobstructed by anything. The entire game globally lit up the exact same way everywhere. No variation.

From what I understand of point lights, they act similarly to real light, in that it dissipates over distance. Am I missing something?

As I understand you need all materials be Emissive, and have no light source around. So that everything will look at their own original color. And since there won’t be any need for a light, there will be no shadows either.

Thank you! Is this the only known method to achieve this? Do I just do some “select all” option and set everything as Emissive? Is there a setting to make every actor that is spawned Emissive?

I just hope it’s not too complicated to implement.

Instead of making material where you use base color you directly output your albedo texture to emissive.

I tried it out, and nothing works for me still. Emissive light ruins the color of the object I put it on, and every other method doesn’t penetrate walls consistently.

Is there anyone that has a solution to this?

Show your material. I already gave perfect solution for this. If its not working then there must be some problem in the material.

You need to do two things:

  1. Put the color you want of your material into the Emissive slot in the output function
  2. Mark the material as “Unlit”

You have to do this for each material. (It is possible to write code to do this for you, given some assumptions, for an entire level, but that’s beyond the scope of a forum post like this!)

Finally, I don’t think you will get the result you want by doing this. It turns out that lighting/shading is important to our perception of the shape of objects. Shadows are also important to our sense of object location. Making everything uniformly lit from all directions without shadowing (which is what Unlit does) will actually make everything blend together, and will make your game look like a bad '90s 3D game.

If you just want that, run your game with the lit buffer, it’s more simple and you have nothing to change in your materials or/and your lights.

Plus, I don’t really like the method of the emissive for that kind of effect, the third solution is to add a Skylight set in movable and disable “Casts Shadows”, all your level will be lighted the same way and if you don’t like the AO you just have to put a post process volum and disable it.

The advantage of this method is that you can still have your “lit” effect and add “next gen” effect if you need to, you’re not stuck with the lit buffer nor emissive materials. Artistically it’s better in everything :).

Oh, sorry, I didn’t understand what you meant until I looked at the default Third Person map in which it has an animated 2D help item. I looked at its blueprints and now I understand that I need to put the color directly into the Emissive slot. Thanks

I still don’t know how to change a whole map to Emissive without doing every single piece manually, and that’s the most important part.

I don’t understand what a “lit buffer” is. I Googled it and couldn’t find anything. I also don’t know what “AO” means.
With the “skylight” option, if I attach a light to each player, how do I make the light uniform? As in not super bright close to the light and fading with distance. Also, does it pierce through walls unobstructed?

I want my game to be lit up fully, with zero shadows. All shadows completely disabled, and all light completely disabled, so the game uses the least possible memory in that department.

Here you can find all buffers of UE4 View Modes | Unreal Engine Documentation and if I understand correctly, you want only the lit one.

I think you can use only buffers you really need as well, I’ve never done it before but I think it’s completely doable to create a custom post process or completely disable effect if you really don’t need them.

AO = Ambient Occlusion, you can tweak fx with a post process volume like screen space reflection, bloom, AO, etc.

I don’t understand what you want to do with the light linked to the player.

I found what achieves the look I want, it’s called the “unlit” view mode (the opposite of what you said, EXpMiNi, so you were close). I can choose “Play” within UE4 and type in the command “viewmode unlit” to get the desired effect.

My question now is: How do I always apply the “viewmode unlit” modifier to the game, especially the finished product?

Oh yeah my bad, it was unlit indeed :p.

I guess you need to find a way to run the command in launch (in BP

Thank you EXpMiNi for taking the time to solve my issue! I now have viewmode unlit as a starting command, and can now add hotkeys to switch between lit/unlit viewmodes to compare them!

It seems you were wrong about that. Unlit mode looks beautiful. The reason I was so keen for it was because I think it looks better than having shadows. Bright lights / dark shadows are distracting and unpleasant to the eye. I actually grew up playing “bad '90s 3D games” as you put it, and I very much enjoy them.

The one thing I have always disliked about UE4 is the way it handles light. It’s too realistic. In real life, light sucks. It’s a necessary evil. We’ve designed sunglasses, window tint, blinds, shutters, curtains, walls, lamp shades, planted trees, and done all sorts of other things to hinder the sun’s effect on our eyes. Why would I want to willingly look at a game that goes from so bright I can’t see properly, to so dark I can’t see properly? I could tweak everything to make sure the game is lit very well, hand-placing and calibrating each individual light, but what would it achieve? I want to make the game I have always wanted to play, and I don’t care if some people think it doesn’t have the best graphics around. Battlefield One and Battlefront have graphics that will kick the sh*t out of any game I could make anyway.

Then I’m happy for you finding a look that you like! Good luck on your game.

Can you show the final image you achieved?