Light target on Torch?

Hi i have this little script. Where i try to change the light color on a torch.
http://kong-kim.dk/ftp/games/ark/fi_lightcolor.jpg
But what do i set as the target to find the light on the torch?

Can’t find the light sorce in the torch? :smiley:

Edit:
How do i in anyway change color and Brightness on a torch??? Can’t seem to find it anywere…

Ok i found out that the color and Brightness is in the emitter. So its not the light color i need to change but the emitter…
So can a script be made that change color on the emitter or du i need to change the emitter template?

The point lights for the torch are in the components section. Here is how It will work by dyeing region 1 the desired color: (thanks to Mezzo)

33caf0e969520b0179391ecad159ca4c77715116.png

It won’t let me upload a pic with the color changed for some reason but it does in fact work.

You could probably take it a step further and add a parameter to the fire particle itself to change the fire color as well.

Hi P0K3r and thx :slight_smile:

I got it to work by changing the particle template. But i really like a script were i can get the parameter for light and fire color and the brightness.
Im working on a system where you add colored powder to a torch and then i change color or get brighter.
But its a little harder then i hope for :slight_smile:

The graph above is a good starting point. There are other nodes that would allow you you to do all that. You would just need to set the different parameters in the particle system then call them in the graph like so:

For intensity:

You could create a (green pin) variable for the intensity that could be adjusted maybe with a menu: Tutorial/Example: Adding custom MultiUse(Radial) menu entry/action - ARK: Survival Evolved - Unreal Engine Forums

Thx alot and i make sense. But im still very new to it, so maybe have a stupid question :slight_smile:
I build it up as in the image. But i can’t find the targets Point Light and the Partical System
The only thing i have out to the left is the emitter and the inventory of the torch.
And for the New Color i used a Make Color Node and set it to the color i want.

If you only see the inventory & emitter, sounds like you’re not on the graph tab or maybe the “My Blueprint” Window is not enabled. At the top of the screen, select “Window” and make sure “My Blueprint” is checked

For the color you have to make a new variable by clicking the +V under “My Blueprint”, here probably easier to do this:

4353bba835885f449100898bf2a843ace2e06131.png

The stuff on the left under the “Components” section should already be there since they are part of the base torch. Particle systems for FPV and TPV fire, sound and lights for TPV & FPV.
Point lights & particles systems, pretty much anything on the left can be dragged to set or get. From what i have found :slight_smile:

Hi again i tried to look at it again. But as you can see in the link there is no lights in the torch. And it works if i play and all and its the same on the original torch.
http://kong-kim.dk/ftp/games/ark/fi_lights.jpg

From what i have read it is the emitter that give the light? So need to get the right so need to get the right parameters from there i think :S

The emitter holds the light and particle system that you want to change the color on. You will have to modify the particle system to have the “Color” parameter though since the particle emitters in the default “StandingTorch” particle system don’t have paramters setup. Make a copy of the emitter and particle system. Link the copied particle system in the copied emitter bp and then link the new emitter in your wall torch. In you particle system you want to change the “Distribution” of the “ColorOverLife” module to “Vector Particle Parameter” on the two fire emitters and the smoke emitter(or more if you want to) in the particle system and assign the name “Color” to it.

You can then do this in the graph to assign any color you want:

Really cool have not tried it yet but will soon.
I can however see you also have Target Point Light 1 and i can’t seem to find? if you look at the Screenshot i linked to :confused:

Except you try to get the point light from the wall torch itself which does not hold it. You need cast to the emitter blueprint first and then you will be able to get the point light from the emitter.

Im in the editor now and i still cant find the light. I build it up so it look 100% like your and i found the particle system but still no light :confused:

You will need to drag from the cast node’s “as” pin and have “Context sensitive” checked to see the variables on the emitter. If this does not help pls post a screenshot of your graph.

Here you go :slight_smile: Did it right and still can’t find it. So don’t know what im missing :slight_smile:
http://kong-kim.dk/ftp/games/ark/lightcolorscript.jpg

Hey looks like i might have messed with the standing torch emitter earlier and added the point light myself(note: don’t edit base files :D). So it looks like the default standing torch emitter has no light component at all. There is a particle emitter in the system that has a light module. You probably want to add a color parameter to that aswell and you should be good.

Haha that happens :smiley:
Will look at it later when i have the time. But thx alot my friend :slight_smile:

Hah! Lol you were trying to edit a standing torch! I thought you meant a hand held torch. Oh well, good to see Mezzo saved the day as usual.
Anyways, if you were doing this on a hand torch it would work. While messing with this the other day I went ahead and made a little flaming sword mod idea I have had in the back of my mind for awhile now based on that original I graph I posted for you and it works perfect!

Haha its okay. I learned alot from trying alot of stuff. And found another way to deal with it be changing the particle system. That way i can make 100% as i like :slight_smile:

And cool mod. have been looking at it on steam :wink:

Ok it do work changing the Particle system but then i have to make every one of them in color.

So im trying again with the script and get the Parameters from the Emitter/Particle system. And i guss i can use the Set Vector Parameter node to do so?
But nothing happens. It looks like the Screenshot above. And i change the particle system to use Vector Parameters…
The only thing i can think of is that the Parameter name in the Set Vector Parameter is wrong. its Color. But do it has to be more like a path or something?