Download

Light shines through my door.

Hi.

I’m very new to game making and UE4.
I get this effect on my door from the light on the other side of the door and I don’t know what I’m doing wrong.

996650a224a8f7ddd5c55f3ab0be4660d2420037.jpeg

The doors are solid meshes, they have proper UVs and there is an animation on them to open and close.
I’m using Cinema 4D R15 and exporting with FBX 7.3 to UE 4.2.

My original post about this disappeared some how in the Content Creation section.

Sorry about that, but there was a problem with the database: https://forums.unrealengine.com/showthread.php?10781-UE-Forums-Outage-Data-Loss-Incident-Today

Do you get any warnings when you build your light?

I don’t get any warnings when I build my light, the only waring I get is when I import my mesh and get:
“Warning Warning: No smoothing group information was found in this FBX scene. Please make sure to enable the ‘Export Smoothing Groups’ option in the FBX Exporter plug-in before exporting the file. Even for tools that don’t support smoothing groups, the FBX Exporter will generate appropriate smoothing data at export-time so that correct vertex normals can be inferred while importing.”

You may want to check your normals.

I’m not sure how C4D handles this, since I hate it with a passion - but you should have an option to cull backfacing geometry in the viewport. Pore over your mesh and check for any visible holes, and then flip the normals as and where they appear.

I have checked faces, normals and vertices on the mesh many times and haven’t found anything wrong with them.

Alright.

Can you upload the mesh? Might help to get a second pair of eyes to look over it.

Probably a low lightmap resolution is causing it -> choose a higher value (e.g 128)

But as Crow87 said, it would help us when you could upload your mesh so that we can take a look at it :slight_smile:

Here is the FBX file for the mesh.

I have played with the resolution, gone so far as high as 512.

As far as I can see your lightmaps are overlapping -> create a 2nd uv channel with proper lightmaps

lightmap.jpg

green -> your mesh with overlapping lightmap
red -> your mesh with correct lightmap

2nd uv + lightmap = https://www.youtube.com/watch?v=z5yc-bKbHyc

I have hade sure that the UVs are not overlapping and that the spacing between them are 3 pixels, but I still get the effect.

909a91d4877161902e01c09534b1b3de73b6010d.jpeg

What is my brain missing?

Do you have any reflections or other lights reflecting? What material are you using? I had a similar problem at one point but I think I fixed it, that was at the point I was just trying stuff out.

In the test scene I have posted I only have one light and use WorldGridMaterial, I have tried other materials but I get the same effect.

128 is maybe a little low resolution for your lightmap, try something higher.

I have tried with 128, 256, 512, 1024 and 2048 resolution and I still get the same result.

I wold guess your doors there are added as movable objects?.

With movers your light map UV’s are of no real use since a mover is lit and shadowed dynamically by default. The “lit from the back problem” I think is caused because I think your mesh is too thin. There are accuracy issues when it comes to self shadowing and that door model is really thin. I suggest you make it like 2x to 4x thicker. But I guess do it incrementally until it works. The idea is to get those cut in details further apart.

I did it 3x thicker in UE4 and that removed the problem.

7314acf1eb676ac4fbe4bcaf8a29374b2cfb3811.jpeg

Thanks Obihb and everyone that came with suggestions.

I just a thought, regarding the dynamic lighting - if you check your light source, there should be a ‘self shadowing accuracy’ option on it. Try cranking it up, and try out the thin mesh again. Seems odd to have to change the form of your objects just to get the lighting to work.

Possibly the shadowing offsets for a thin object.

Hi Narater,

I messed with your Mesh for a little bit this morning trying to solve the issue. Attached you’ll find two images.

The first is a slightly tweaked UV for the lightmap vs the original lightmap.

In this image on the left is the tweaked lightmap (can be seen in the second image) and the right is the original lightmap. You can clearly see that light bleed is happening on the original.

DoorNoLightvsLightLeak.PNG

Here in the second image is the original UV for the texture. I did a check to see if there were any overlapping UVs and there were. They are the ones in the top right and left corners. Moving those up I then reimported this into UE4 and set the lightmap resolution at 128. Both meshes in the image above are using a 128 lightmap resolution.

ORiginalUValtered.PNG

It wouldn’t hurt to make your mesh a little thicker as you’ve indicated you’re doing, but having a properly setup lightmap can do worlds of good as well when it comes to getting the look you want! :slight_smile:

If you run into issues or have any questions feel free to ask!

Thank you!

Tim

Hi Tim.

I have made the door 2x thicker and that is as far as I want to go. In what way did you tweak the UVs for the lightmap?
23bdfd90884127f26f96bbd94f1f6c4d13c3c674.jpeg
What did you find was wrong with it?

What about what Obihb said that movable objects lightmap are of no real use?

It only slighty helps if I set Self Shadowing Accuracy to a higher number.