Download

Light Shafts go "disco" when camera is near small buildings

Hello. I am sorry for my thread name but I didn’t have any better idea of how to name it :stuck_out_tongue:

I have Light Shafts activated in my light source. They are working as they should and this is a problem :stuck_out_tongue:

When I look in object far away they are looking great, but when my camera is close to some small building my sky is dark, then camera is going away from that building and sky is brighter, then my camera is again going close to building and it goes on and on. I don’t want to change my camera route and I do not want to turn off my light shafts.

Can I do something about it ? There is “Occlusion Depth Range” but this is “Everything Closer to camera than this distance” maybe something like “Everything further away than X unit will cast Light Shaft” ? Can You please give me some advice how Can I deal with it ?

Thanks and Cheers !

can you show us that as a screen?
And what OSX do you use?

It is hard to capture. I will try to explain this better.

My camera is in open space, everything is fine. My sky is a little bit brown (night with bronze atmospheric fog). Camera is going near small building. Light shafts from ceiling are starting to be visible - my sky (above building) is becoming darker. Next camera is going forward - building is ending and my sky is once again a little bit brown. Then my camera is once again going close to small building. It is working 100% properly I know this, but this is a little bit bothering me right now :stuck_out_tongue:

I am using UE 4.10.1 and Windows 7 64 Bit.