Download

light seeping and blotchy lighting

hey guys, I have a problem with some surfaces

light map res is at 2048, and built at medium setting. higher doesn’t make much difference.

any help would be much appreciated

Make sure that your walls/ceiling does not extend beyond each other, and it can also help if you have geometry on the other side to block outside light. For the outside surfaces, make sure your walls actually have thickness, so there’s some space between one side of the wall and the other.

Also, make sure that your lightmap UV mapping is as good as possible. For best results, your UV’s need to have as few seams as possible, so for instance on your wall you would want the paneling to be modeled into the wall instead of being a mesh that isn’t attached and then you could map it to where it’s a single piece in the UV mapping which would mean that the only seams would be around the edges.

thanks for the reply

I still cant find find a solution.
I do have a separate block enclosing the whole scene. (1 feet thick)
I have included a few more screen shots with settings.
non of the Geo intersects,

any further help would be much appreciated






I am not an expert when it comes to lightning but I can tell that, in your UVs, those lines are actually too small. You should try using those empty spaces to give more width to them.

Disable normal maps contribution to lighmass from project settings. Disable compression from lightmaps.

You could always try a resolution of 2048 since you have alot of geometry on that same lightmap!

Your lightmap UV’s are bad, don’t use automatic flatten UV’s because it will not give a good result. Like I was saying, you can map it perfectly for a wall. And make sure your floor/ceiling exactly matches up with your walls and doesn’t extend beyond them. Also, set your static lighting level scale for Lightmass back to 1.0, it’s best not to change that.

how would you suggest I lay them out?

thanks for the reply guys. much appreciated

I would do a planar mapping of the wall and then do a relax by face angle and it should flatten pretty much perfectly, then just make sure that it doesn’t go beyond the 1x1 space

hey.

how do I Disable normal maps contribution to lighmass and compression from lightmaps?

I am still a bit beta when It comes to UE4

In project setting under Rendering section.

sorry I cant seem to find it. unless I am being dim. all I found was compress lightmaps in the world settings tab

I and using 4.7.0

You already have it disabled. It’s called “Use Normal Maps for Static Lighting”

awesome… I am still getting the blotchy on the skirting and nothing I do seams to be working. laying out the uv’s diffrently etc

Can we see your new UV’s?

so I have sort of managed to fix the blotchyness by massively stretching (thickening) each piece. is there a way to make the area bigger to lay them out? or what is the recommend min size of each piece as I ran out of room, I wanted to make each piece as big as possible.

also still getting some bleeding on my ceiling.

thanks!

Blueprint_Settings.pngBlueprint_Settings.png

skirt uv