Download

Light quality not changing to 'Production'

Hiya! I’ve just started using UE4 and i’m starting off by following tutorials. I’m having an issue with the lighting quality setting. The word Preview is all over the place and i’m trying to change the lighting quality to the Production setting, but I click on it and nothing happens!
productionLighting.jpg
I’ve been told that it should start ‘Building Light’ but it doesn’t! If anyone can help that would be great! Thanks :stuck_out_tongue:

What you’re describing is actually two different sets of options. When you adjust the lighting quality to Production this is only setting the quality level to use for the build but does not initiate the build process. To actually build the lighting you’ll want to clickthe Build button in the main toolbar or use the drop-down above and select Build Lighting Only.

If you’ve not seen the Lighting Quick Start guide this may be helpful to walk you through the process for static lighting in the level. You may not need to do all the steps but I would encourage anyone to look over it just to see what is involved and to get that understanding. https://docs.unrealengine.com/latest/INT/Engine/Rendering/LightingAndShadows/QuickStart/

We also have our Wiki Lighting Troubleshooting and Tips guide that has a lot of common issues that come up if you’re interested here: https://wiki.unrealengine.com/LightingTroubleshootingGuide

Thanks so much! Looking back that seems very obvious… Thanks again!