Download

Light Propagation Volume now works with Emissive Material!!

Special Thanks to Xodroc for his topic on LPV.

How to:

1: Follow these instructions to activate LPV plus add a directional light with Affect Dynamic Indirect Lighting turned on.
2: Create a new Emissive Material with Use Emissive for Dynamic Area Lighting turned on (See Image) and apply it to your mesh on level.
3: In your dynamic directional light set its intensity to 0.004 (Anything below that disables Emissive Lighting).
4: Enjoy!

Here are some screenshots.

With Emissive Lighting:

&d=1400824931

Without Emissive Lighting:

&d=1400824983

We can also modify Indirect Lighting via Material:

&d=1400825056

Rather interesting, thanks for the info. =)

Great stuff, but does this mean you have to enable LPV’s by compiling from source?

Also is this baked or dynamic?

This is great, thanks!

https://warosu.org/data/fa/img/0067/75/1377545595996.jpg

Should work with the pre-compiled version(4.1 and above) from the launcher as well since enabling it only requires adding a line to a config file, though I’ve only tested it with versions I compiled from source.

It’s dynamic, lightmass is disabled, just follow that wiki link at the top.

Like I said, I heard about Emissive LPV on Twitch, Sneaky devs.

Have fun.

Is it possible to have the emitting light from emissive materials working on top of baked environment?.

I dont think its possible right now.

LPV is working with baked lighting just fine.
Just bear in mind I tested only with baked SkyLight.

Is this with 4.1 or 4.2 snapshot?

4.1.1 version compiled from source.

sample download please i use ue4.10 and this not work for me

Hi AkangGG,

You will need to make sure that your Material has this enabled in the attributes for use with Dynamic Emissive. You will also need to make sure that you have a Directional Light in your scene with Dynamic Indirect Lighting enabled.

Also, make sure that you’ve enabled r.LightPropagationVolume=1 in the the ConsoleVariables.ini file in your engine installation folder.

You will also want to add a Post Process Volume that is unbound so you can adjust the LPV properties for a better look. You can test to make sure that you’ve enabled LPV by using the Show > Visualize > Light Propagation Volume flag.

I intended to create a fluorescent lamp, followed all the instructions, re-checked a million times over reading the comments and whatnot, and it turned out so glitchy and unstable.
It doesn’t light up actors even if they’re right next to it, I move it one cm to the side and it stops working, any clues?
It seems that the best way is still to fake it by making the lamp emissive just to make it look like it’s lit and add a secondary light source.

Works then, 4 years later it’s broke. Tests in 4.18 indicate that LPV does not take light from Emissive materials anymore, or point lights, and any light injected is not occluded by geometry. Because it is an experimental feature I guess they dont really take it into consideration when updating the engine so a lot of new features have broken it. Anyway, Its about time they implemented a realtime GI solution : /

Hi Toku - emissive materials and occlusion can be re-enabled by disabling DBuffer decals.

https://answers.unrealengine.com/questions/665365/417-lpv-sky-occlusion-bug.html

Its possible to make this volume overlap a static mesh?
https://answers.unrealengine.com/questions/861595/view.html

There is no such thing as a “Volume” for LPV. LPV is a post process around the area of the camera for dynamic indirect lighting.

Hey, has anyone managed to get it working in 4.21? I doesn’t work for me, here is how it looks like: Imgur: The magic of the Internet

Hello Slavq. I guess you need to disable DBuffer decals in the project settings for it to work.

Hello, thanks, but it didn’t change anything in my case, it still looks the same after disabling DBuffer Decals.
… Maybe 4.22 will fix some stuff in this area.