Light Propagation Volume does nothing in 4.15.2

I’ve followed multiple guides (most of which all give the same steps) to set up light propagation volumes. I’ve done this both in my project as well as a brand new fresh project. Above is a test scene with all of the LPV steps completed and the LPV visualization turned on. No settings (Intensity, et al) make any difference. Setting the SkyLight to movable makes all shadows pitch black. No light is bouncing.

Are light propagation volumes broken in 4.15? Am I doing something totally wrong? Any help is appreciated!

It works fine for me.

There is one problem that to enable it you need to add r.LightPropagationVolume = 1 to ConsoleVariables.ini in engine folder. But sometimes it removed from that ini, maybe by editor or I don’t know.

I tried to add this file into project config folder but that didn’t work.

Nevermind, I’m an idiot. I have duplicate UE4 folders in completely different places. Thanks for the help regardless!

can you tell me what exactly was the issue? I also cannot get lpv to work atm yet all settings seem to be correct, even after checking the console in editor to verify

I had all the right settings and checked all the checkboxes. UE even appeared to generate all the data when I switched lightmaps off, but light wasn’t bouncing and no LPV settings in the post process volume would have any visual effect whatsoever. Turning on LPV visualization would bring up text info but no actual visual data.

The problem was I had similarly-numbered versions of UE4 installed in Program Files (x86) and that is where I added the console variable. Once I added the console variable in the correct folder where I was actually running the engine from it all worked.

hmm, I’m sure the setting it set because the console says it is. lights are movable, dynamic gi is set to on. post is boosted, nothing works :frowning: