Download

Light Propagation Global Illumination Issues

Hello,

So this is my first post here guys but I have been using the forum daily. Up until now I have managed to solved all my problems so thanks to the awesome community for your help.

The issue I’m experiencing is getting Dynamic global illumination working. I’m creating a game play demo as part of my university work. We have been set with the task of designing a game (Concept to prototype) as part of a group project and the presentation deadline is creeping up 0_o

I have read every thread I could find on the subject and they all give the same instructions as to activating LPV’s and DFGI.
I followed the instructions and nothing happens when I set it up in my project. To clarify these are the steps I have taken to activate LPV’s

  1. Added This line into consolevariables.ini: ;r.LightPropagationVolume=1

  2. checked ‘Force No Precomputed Lighting’ in world settings

  3. Enabled ‘Dynamic indirect lighting’ under the movable direct light source

  4. added a post processing volume to control light propagation

  5. even tried disabling “allow static lighting” under project settings/engine/rendering

I’m using Unreal Engine 4.7.3, a GTX 980 GPU with shader model 5.0 activated and scaling set to epic.

This has me absolutely stumped! I’m sure it must be because of a conflict in my settings or something. See the screen shots for details

Thanks in advance guys :slight_smile:

Try removing the ‘;’ from r.LightPropagationVolumes=1 in your ConsoleVariables.ini

By using the ; you’re essentially commenting out the command so it will not work.

that should resolve your issue.

Hey Tim,

Thanks for the quick response :slight_smile:

So I removed the ‘;’ from the consolevariables.ini and I still receive no dynamic GI in my scene. I even started a new project with a new setup and it still results in jet black shadows.

Is there any other settings that must be changed or possibly causing the GI not to work?

Thanks again.

*** Never mind it seems to be working for some reason now***

Glad you got it working. :slight_smile:

Have you set the post process volume to unbound? Also check under showflags > visualize > light propagation volume to see if the effect is being applied. Also check under show > lighting components >Gi

I have all the same settings as you but my shadows are completely black. Did you figure out how you resolved it?