Light pops of based on camera distance and overlap

Hi,

I have 3 overlapping stationary point lights and one skylight which is using cubemap to light up a movable mesh in a completely blank scene, after built the scene and lighting I realized when I move camera close to my object lights start to pop off, its working when I only have one light turned on,

but after turning on 2d light the problem appears, also mention that for the purpose of the project I need to use a very low camera FOV, between 28 and 14 and I realized that also affects the issue. please help me how to resolve this.
Im using PC spec as follow:

2* Intel Xeon 5620 processors
nvidia Quadro 2000 Graphics
12 GB RAM DDR3
Win 10 64bit

Thankyou

Anyone? :slight_smile:

Hi Korosh,

This is likely caused by the bounds size of your mesh. As the camera distance increases (not sure how this works with Camera FOV since there is some magic there that I’m not 100% sure of), the shadows will decrease in quality as a LOD so that it’s not as expensive. I wasn’t able to get as clear an example as you have here, but I’ve attached a simple project with the head model we have from Content Examples. Can you recreate your lighting setup here and I can take a look and offer some tips that could probably help you sort some of this out for better results.

link text

If you’re not able to set it up there, then details about your entire lighting setup, properties changed, Location in the world, Scale of the actor in question, etc are really helpful here.

Thanks!

Tim

Hey Tim, thanks a lot for respond. I’ll look into it and get back to you ASAP.

I adjusted the project exactly as my own and after I built lighting I’m getting the same issue, just mention again that this problem of lights popping off is happening when the camera is close to the model, my project is to setup studio lighting to get headshots out of my model in UE4 so I need to be very close to the model.

Thanks!

Another thing that happens is when I turn off one of the other lights, it seems to resolve the issue. But again if I get closer to the model with my camera it happens again, in fact the more lights i have the more distant I should get from the model to prevent the lights pop off thing :I

This is an odd one. Doesn’t seem to do it for me. I put the camera in Pilot mode, like your screen shot indicates and moved back and forward a number of times with no change. When moving the camera in the light only goes away when I clip the geometry of the head, which is expected.

124809-lightpop.gif

Beyond this some things to check would be to make sure that the Engine Scalability settings are set to EPIC, maybe even Cinematic if you’re only using this for high quality rendering versus GameDev. One thing you could try too just to see if it works is to increase the bounds of the bust slightly. Try something like 1.15 or 1.25. You want to be careful not to extend these too much as the bounds of the actor can be affected by lighting quality with these lights being so close. Other than that I don’t know of anything else to check other than possibly something with the PC specs being a factor.

Yes I’m afraid its an issue with my PC specs, it doesn’t seem to work. Thank you Tim.