Download

Light leaking with one sided geometry and dynamic shadows?

Is there a trick to get rid of the light leaking with one sided meshes? I can get it to cast shadows with “cast shadows as two sided”, but the light artifacts are still present.
A workaround is the make the mesh whole, but that takes a lot of time.

Light leaking through.

No artifacts with the sun in front of the mesh.
7b79e542832032c4f41e45e20653ee25e70f5216.jpeg

I believe making your rock material double sided should fix this. Give that a try.

Making the material two sided or setting “cast shadows as two sided” only fixed the shadow on the ground.

Strange, that should fix it. I’m assuming you’ve double checked your light angle? Have you also tested a large bsp behind the meshes to see if the effect is still there? That could probably help to narrow down the cause, though it sounds like those options aren’t working properly.

It seems the cascading shadow maps are not working properly. Shadow as two sided or disable backface culling (render two sided) does not fix the self-shadowing, only the ground shadow.

I tested making the mesh whole and that fixes the problem. But this takes a lot of time and is not an ideal solution.

Agreed, I didn’t expect you to use it as a solution but to narrow down whether it was a thing with shadows overall or those particular options aren’t working as they should. You should probably put this up on answerhub if you haven’t already.