Download

Light Leaking Through Walls

https://forums.unrealengine.com/core/image/gif;base64
​Alright, so I have literally scoured the internet for solutions to this problem and haven’t really found anything yet that fixes my problem. Everything I’ve come across so far seems to just mask the issue instead of addressing the root cause of the problem. I am extremely new to Unreal Engine 4 so please forgive me if this seems like a silly problem to have.

I have been trying to figure out how to fix light leaks in a sealed room and started with some basic geometry just to try and get the hang of it. I used the 400x400 static mesh wall that comes in the Starter Content.

I made sure that the geometry is snapped together to create a tight seal for no light to come in. Here is an example:

432f3b1c348e9abba9457d08c5f8de8b50e13289.png

This is what the inside of the box looks like:

364a4ad7e53c222521ca38445a048eecfd85c8c8.jpeg

I’ve looked everywhere to try and figure why I’m still getting these leaks. I even tested this geometry out in a new First Person project and when I did it turned out not to have any leaks so I’m just trying to figure out why it won’t work in this project I’m using.

If anyone can provide me with any solutions it would be greatly appreciated.

Those corners are paper thin to lightmass, and due to said low precision, it passes right on through, the solution is to expand the walls slightly to form a full box, not a box minus some parts around the corners. You can just shift in 2 side walls or scale them a bit.

Hi!

I’m not sure about the starter content walls, never used them but this is the same way I build my walls for archviz and this is the best approach I’ve ever found to have proper lighting!
What is the lightmap uv for that wall mesh?
What is the lightmap resolution?
What are your lightmass settings?
I’m guessing that your lightmap resolution will be too low and your lightmass settings are also low for this precise scene!

I think starter walls have issues with light leaking for certain setups. I’ve tried a number of different combinations of directional + skylight mobilities (static + stationary, stationary + dynamic, all stationary, all dynamic, etc), and it occurs in almost every case. I’ve solved it different ways, but most solutions have a caveat or two at least, such as it causing something else to break or become problematic. One of the approaches that may not cause a new problem, or be easier to solve that new problem, is utilizing AO as a filler. But it’s not an automatic, pristine fix for every case. Neither is increasing lightmap resolution. The fact is you can overlap meshes and solve that problem sometimes, and not have to increase lightmap resolution beyond 256 for basic walls. It was done in earlier versions of Unreal Engine, so why would it suddenly be impossible in the newest versions? One way to use AO is place a PPV (bound so it’s not covering the whole level, only the volume of space it surrounds) tightly surrounding the walls / structure, then reduce the Blend Radius to 0 or really low. The idea is to overwrite the lighting / shadowing which is immediately surrounding the structure / meshes with AO, and prevent the initial lighting computation (before placing the PPV) from getting inside the PPV. I used it before and it worked, but perhaps it was another aspect that allowed it to function that way to remove light leaking.