Light leaking problem with solid geometry

Hi guys!
I have weird light leaking problem here. I use regular stationary point light for lighting a small room which is part of a bigger mesh. But when I increase intensity or attenuation radius of my point light, indirect light starts leaking on opposite side of the wall.

I have whole mesh without any holes except floor. It goes as a different mesh, but still cause same problem which is really weird because it looks like light is leaking thru the seams at the same way as thru solid geometry.

I can show you on this screenshot of the floor what happens exactly. I guess rest of the walls have the same problem.

This light leaking problem affects not only geometry but character’s model too. Looks like wall just does not exist.

I’ve found few posts with similar problems, but no one of them gave me the answer.

Do you have any idea what is wrong with my mesh or how I can resolve this problem.

Hello astronaut61,

In order to better understand this issue I would like to gather some more information from you.

1.) What is your lightmap resolution set to?
2.) Can you link a copy of your DxDiag?
3.) Do you have your engine scalability set to epic?

I will also link you to a troubleshooting guide for lighting. If you are still having this issue after providing this information and looking through our troubleshooting guide I will continue to assist you in solving this problem.

Hi ! Thank you for you response.

  1. My lightmap resolution is 512x512

  2. How can I get this DxDiag?

  3. It is on Epic.

Thank you for link, but I’ve read this guide. It is mostly about movable light and I haven’t find answer there.

Also I’ve found some kind of solution by myself. I reduced indirect lightning smoothness and static light level scale. It fixed problem whith leaking on walls. But I still have wrong light on character model. Also leaking on walls comes again when I increase intensity of point light.

1.) Try setting this to 1024

2.) Your DxDiag is your computers specs. You can go to your computers Start > and search for DxDiag. You can bring up your systems specs by clicking on the program that comes up after the search and chose to Save All Information. This will save your information as a .txt file and you can link it here.

The answers you found can help with reducing light bleeding.

1.) Do you have a lightmap importance volume within your scene?
2.) Try adjusting your Shadow Bias and and Shadow Filter Sharpen to reduce the light bleed in your Directional Light. Adjusting the shadow bias too low will give you banding. You will have to adjust between the two to find a good setup that fits your needs.

Thank you for answer! I will try next time. I’m happy with my result for now and gonna move next.
Have a good day:)