Light Leaking in Corner

Hi, I have problem with light leaking for some time. I tried everything, red everything related to that topic and still can’t find solution. Here is what I get

https://dl.dropboxusercontent.com/u/76398249/image1.jpg

This was built in production quality with indirect light quality of 6 and smoothness 0.75. It looks the same with quality of 10 and smoothness of 1. Directional light intensity is 5 and spotlight intensity is 1. I tried different lightmaps with small and large padding and resolution of 1024 and no matter what I do it always has this leaking in this corner and on the top of that wall. I also tried changing diffuse boost value of that and surounding walls and assests but still nothing.

This is how my latest lightmap looks. No inverted polygons

https://dl.dropboxusercontent.com/u/76398249/Screenshot%202015-03-16%2018.16.59.png

If anyone has solution or advice for my problem I would be very thankful

Hello saska987,

Your UVs look clean and well padded, so that should not be the issue. If this section of the wall is a modular or individual piece, try selecting the mesh within the Viewport and turning on ‘Cast Inset Shadow’ within the ‘Lighting’ section in the ‘Details’ panel.

Let me know if you are having trouble finding this setting, or if you have tried this suggestion and are still seeing the light bleed.

Thank you,

Andrew Hurley

Hi,
Thank you for your answer. Yes, that wall is individual piece and I tried checking ‘cast inset shadows’ but I got the same result. I have this issue with two other interior projects too. I’ve been trying to find solution for more than a month already and I’ve become pretty desperate.

Hey saska987,

No problem. Would you mind showing me your Static Mesh settings? Particularly the UV channels you are using for your mesh as well as the build settings?

Also, you still might want to try messing around with the Lightmass settings that you had already mentioned. Try setting your Smoothness value to something like 0.6.

One of our team members has comprised a great bit of information on how to troubleshoot Lightmap issues where you might also find a way to fix your issue.

Lighting Troubleshooting Guide

Let me know if you are still not able to get it to light correctly, or if one of the suggestions within the Guide worked for you.

Cheers,

Andrew Hurley

Try to snap UV for lightmap to texel. Maybe it help you. Read this thread.

Hi, Andrew.
This is how my SM settings look now.

https://dl.dropboxusercontent.com/u/76398249/Screenshot%202015-03-18%2008.41.40.png

https://dl.dropboxusercontent.com/u/76398249/image2.jpg

I lowered resolution from 1024 to 512. I I also tried building with IL quality of 10 and smoothness 0.6 but light bleeding is still there, the same as before and shadows in other parts of the scene became pretty nasty. I already tried solutions from Lighting Troubleshooting Guide but it didn’t have effect.

Hi, thank you for your answer. I tried snapping UVs, made grid for resolution of 512 (divided 1 with 512) snapped vertices and this is how problematic part looked in max

https://dl.dropboxusercontent.com/u/76398249/Screenshot%202015-03-18%2009.28.13.png

When I made fast preview with medium building settings and IL quality of 2 it looked good for the first time since I made this scene, but the rest of it looked bad. Than I built lighting with production (epic) quality, IL quality of 10 and smoothness of 0.6 and light bleeding came back.

Hey saska987,

I have been running some tests to try and figure out what could be causing your light bleed, and a team member mentioned offset pivots. In other words, go back into your mesh and be sure the pivot for the walls are snapped to the end vertices.

Also you mentioned as soon as you changed the Indirect Lighting Quality and Smoothness, the light bleeding re-appeared. Do me a favor and return all these values to their default state and then rebuild your lighting in ‘Production’ quality.

Incorrect Pivot Location

I attempted to match the values you mentioned for your lights in the scene to get the closest results.

After you have tried these suggestions, and still are not getting close to the desired results, let me know and we can troubleshoot further.

Cheers,

Andrew Hurley

Hi, sorry for late answer. I tried that but there was still light bleeding. I found some solution for now by adding movable point light that doesn’t cast shadows at all. There is no light bleeding now and everything is brighter, but that can be corrected with postprocess volume. Thank you very much for your answers

Hi,
This problem of light leaking is solved when i change static lighting level scale to 0.4 and NumHemisphereSamples to 512 in BaseLightmass.ini file.
If anyone changes the value of static lighting level scale then also make changes in NumHemisphereSamples value.