Download

Light leak issue

Hi,

I have a light leak issue on my level. I´ve tried most of the solutions I found online but they didn´t fix it. I´m using a lightmap resolution of 1024 on the walls and 2048 on the ceiling. I have 4 on indirect lighting quality and 0.6 on indirect lighting smoothness on the world settings. All those lights are static spot lights.

Thanks, Claudio.

0577779cc1c2094b11d570ce2184bcae3168494a.jpeg

fd7202d0f24a9881573ead2e1a1e7c3ee9f19c1f.jpeg

6c546ddfd14b5c1422e52c0dcdda17e61882028f.jpeg

Those look like the artifacts from the heavy amount of smoothing that happen when you build lighting on Preview. Did you choose Production lighting quality before the build?

Thanks Daniel. Yes but I was using Koola’s baselightmass ini setup. I guess some of its settings doesn´t work on interior scenes. I´ll try again changing some of its values.

Also, make sure that your ceilings don’t go past the walls, if it’s just a plane that covers everything then the parts that are hidden will bleed to the visible parts.

Ok, I’ll do that. Thank you.

Hi, I´ve tried everything you said and I´m still having the same issues. I made individual ceilings for each room but the light still looks terrible. I also made a black box outside the walls and over the ceiling. Is there anything else I should try? This is how it looks now in production quality.

Captura de pantalla (61).jpg

where are your lights?

Those spotlights (there are 4 of them) + a directional light outside.

97f5bdc0a704aec6f3c027427475933613884150.jpeg

Try setting your lights to Static, and make sure there’s something outside of the building that will block the directional light.

The spot lights are static. There is box outside the meshes so its dark inside. Are there any settings I should change?
Here is a screenshot of the inside of the ceiling.

817924e626f2862fac6f103502718b8e0f480ee6.jpeg

Claudio is it possible to share the meshes in fbx format just for the wall and ceiling? It could be either vertex placement or uv`s thats causing the problem.

Thanks Paul. You can download the file here: https://drive.google.com/file/d/0B9pUR5g3xaLNZWlyek11Uy1aWUE/view?usp=sharing

The UV’s I´m using are the ones created by unreal when importing the fbx.

Today I tried building the light again without the directional light. The result was the same.

Hi Claudiobdlv,

Using the assets you’ve provided here are my results:

190289c65308e1c5ac4e204904ac7aad30cbd252.jpeg

I have used 4 static spotlights placed along the corridor with a low intensity (500) and a larger outer cone angle (80).

I’m using production lighting quality along with a lightmass importance volume.

I’ve selected all the meshes and used an override lightmap resolution that is set to 128.

Aside from these changes I’m using default settings. I don’t use Koola’s settings as he has mentioned a number of times he just randomly tweaks settings until it looks the way he would like and I don’t keep these on file to pull up either. The majority of settings he has adjusted can be adjusted via the World Settings > Lightmass tab without editing the .ini file.

If you’re not able to get lighting like this with the settings I’ve used, I would recommend ditching the adjusted ini file setting and reset back to default to see where the problem is happening. We can then work from there and see where the hiccups are happening. This is the best way to rule out things that may not be quite right.