Download

Light interior with planes gives horrible shadows

Hello I have this problem!

I’m using white planes for lighting up my interior like the one in this tutorial : https://www.unrealengine.com/blog/simulating-area-lights-in-ue4

The interior gets all the light right, but the exterior looks horrible! I tried checking and unchecking different settings but the only way to fix it is disabling the spotlight’s attenuation radius. If I disable this, the light in the interior gets a lot darker and bad.
Is there any other way to fix this? Even if I disable visibility of the planes looks bad :frowning:
The red floor has a lightmap resolution of 1024 so I think its enough, but light looks sooo pixelated!

floor.jpg

Here are the screenshots of my settings

This is the plane :

18470aef3b873f1bdddabcca5246b952143bb5dc.jpeg

And this is the spotlight :

8700dd48b0759e6f8f806490f23270a078e87c32.jpeg

I think ,but not 100% sure, that you have to untick cast shadows on the spotlights! But bounces cards are usually just good for windows you can’t see on the other side. Notice it’s always 100% interior scene that use them!

Also 1024 could not be enough if your floor is very large. If it’s too large, split it up in multiple parts or try 2048!

Thanks heartlessphil, but sadly that didnt work neither. It decreases the interior quality. I also tried with 2048 resolution but nothing. I’ve been using this technique only for interiors but this time I have to go out in the game.

The reflector planes might be too far away from your windows. Again, I’m not sure the bounce cards/reflectors is a good solution for interior+exterior levels.