Light building stuck at 0%


I’ve tried to build the lighting for my project for about 4-5 hours but it’s stuck at 0%. When i cancel the light building I get alot of warning messages.

“Instanced meshes don’t yet support unique static lighting for each LOD. Lighting on LOD 1+ may be
incorrect unless lightmap UVS are the same for all LODs.”

There are also a few warning messages that tell me:“The total lightmap size for this InstancedStaticMeshComponent is large, consider reducing
the component’s lightmap resolution or number of mesh instances in this component”.

My landscape size is about 2x2 km and there are a lot of trees . I have reduced my lightmaps (and texture resolution) but maybe I’ve missed to optimize some of them.
I also have som high poly meshes in my scene that’s not optimized yet. Could that have any impact on the light building issue, the high poly count?

Any help would be appreciated.

Thanks in advance!

My computer specs:
CPU: Intel Core i7-8700K CPU @ 3.70GHz
GTU:GeForce GTX 1080 (8192 mb)
RAM: 32 GB

There could be some hidden error, to better understand what is going on open Swarm log(swarm logo in the tray)


Even I am facing the same problem … Building light stuck at 0 . My scene is 4 BHK apartments. I tried different settings in the world setting.
I could not figure out the problem

Thanks in advance

My system spec

AMD threadripper 3990x ( 64 core / 128 t)
Ram:64GB Ram
GPU : GTX 1080ti