Light Building Quality

Hello everyone,

I tried to rebuild my Level with “Medium” or “High”. At 97% or 99% I only get the message that Light building failed. I don’t get any Error Message or something else. Whats going wrong here?

Thanks =)

Do you have a lot of foliage or lots of other meshes? Is your map very large? If so then you could be running out of RAM

Well I can tell you, that 1600 objects must rebuild. And I only have 8 Gb RAM. =/. Well in this case i will try to build my level at university with a much better computer.

I remember reading someone say that you can use “layers” to only build part of the level.
If that does work you could split your levels into pieces and place them into there own layers.


Okay I was able to rebuild my level in “high” quality but i still have problems with baking my static meshs which are inside of shadows. Same Object covered completely with sunlight is baked correctly.

Here is my light map:

Merge those meshes–since they are low poly, you don’t get any advantage by having them separate, instead you increase the draw calls and save hardly any memory. The lighting is that way because lighting gets processed on meshes individually and settings like smoothing will make the lighting slightly different between meshes.

Also, your UV mapping could be better, the front part could be one UV island instead of having the outside and then the inside separate.

Also you need to bake on production quality if you want to avoid artifacts and seams.

Okay i will try to rebuild in production Mode. when you said Settings like “smoothing”… What does that mean? Is it a Setting in unreal or 3ds Max? And where should i merge those meshes in 3ds Max or unreal? I have 10 different houses in this Map and I thought the easiest way is to put the Single Parts together as i saw in Most Building Tutorials…

Smoothing is in the Lightmass Settings for your level in UE4. Lightmass renders with samples, so when it’s calculating the light rays it has to smooth the samples together otherwise it looks noisy. You would want to merge the meshes in 3ds Max, you’ll get better results that way. I would fix the lightmap UV’s first though.
Modular workflow is for other types of meshes, for these cases like you’ve setup it doesn’t work well. You only want to do that if it’s got a fairly high polygon count and you want to save memory by reusing the mesh, or if you have no other choice due to your game design.

Ideally, modular meshes shouldn’t have large flat surfaces like in your example. This above example works much better, seams are hidden because of how the mesh is designed.

Okay I will give it a try. So is it better to merge my modular Parts in 3ds Max or is it better to create one new Single mesh for the complete basement for my example?

It’s best to only merge the modular parts that are particularly small/flat and are right next to each other (which causes those lighting errors). Those pieces with the messed up shadows, say you have 5 of them next to each other, that ends up being 5 draw calls just for that little area with bad shading. If you merge those (Not every piece in the entire level, just small groups of them) you reduce them down to one draw call, with shadows that are much better because the entire surface is calculated together in the light bakes.

Merging the entire basement area into one giant mesh would give all sorts of ugly shadow errors.

That’s actually 10 draw calls, one for the mesh and one for the material.

Could you explaing what you mean here? All draw calls use some sort of material. Materials are just shaders. Meshes can’t be draw without shaders.

Well quite all modularparts are very flat xD. So i think i have to merge the complete House in 3ds Max…

What can i do if i have to use those flat meshes as a modular Part. For example my Racing Track is made with the spline landscape Tool and here i have to use a modular mesh. And for a Smooth Track i Need quite flat meshes…

right, but there’s a draw call for the mesh and then an additional draw call for each material that a mesh uses, so most meshes are 2 draw calls.

So what can i do if have to use a flat mesh like in this Thread ?

In this case i can not merge my objects with 3ds Max xD…