Download

Light Building Problem! Help me!

Hi everyone
I have problem with Build Lighting in each level (W7 64bit).When I Build Lighting Swarm Agent show me Message: “The Lighting build failed! See the log for more information”.
Anyone can help me? It’s very important. (Sorry for my bad english)

Log UDK:

Log: LIGHTMASS: Quality level is 1
Log: Deterministic lighting is ENABLED
Log: Lighting will be slower to complete…
Log: Running Lightmass w/ Deterministic Lighting ENABLED
Log: Running Lightmass w/ ImmediateImport mode ENABLED
Log: Running Lightmass w/ ImmediateProcess mode ENABLED
Log: Running Lightmass w/ Sorting mode ENABLED
Log: Running Lightmass w/ Mapping paddings ENABLED
Log: Running Lightmass w/ Mapping debug paddings DISABLED
Log: Swarm launching: …\Win64\UnrealLightmass.exe 9564F2A14C3B8ECF42A51F861C7FDF0A
Log: LIGHTMASS: Writing scene settings: Quality level 1 (1 in INI)
Log: Swarm will be allowed to distribute this job
Log: Error, EndJobSpecification failed with error code 0
Log: Error, CloseJob failed with error code -13
Log: Illumination: 5.32 sec (0 ms encoding lightmaps)
Log: Lightmap texture memory: 0.0 MB (0.0 MB on Xbox 360, 0.0 MB streaming, 0.0 MB non-streaming), 0 textures
Log: Shadowmap texture memory: 0.0 MB (0.0 MB on Xbox 360, 0.0 MB streaming, 0.0 MB non-streaming), 0 textures
Log: Start RegenerateProcBuildingTextures (0 buildings)
Log: Finish RegenerateProcBuildingTextures (Took 0.000000 secs)
Cmd: MAP CHECK DONTCLEARMESSAGES DONTDISPLAYDIALOG
Log: MapCheckForError: Show Errors WorldInfo Untitled_7.TheWorld:PersistentLevel.WorldInfo_0 Maps need lighting rebuilt
Log: Build time 9.88 sec
Log: Save=45.986303
Log: Moving ‘E:\UDK\UDK-2014-02\Binaries\Win64…\UDKGame\Autosaves\Untitled _7_Auto2_save.tmp’ to ‘E:\UDK\UDK-2014-02\Binaries\Win64…\UDKGame\Autosaves\Untitled _7_Auto2.udk’

First Swarm Agent Log:

2014-05-03 19:55:54: [Interface:TryOpenConnection] Local connection established
2014-05-03 19:55:54: [Job] Accepted Job D6FC5EE1-4DED45DA-F46CA391-04E6A9BD
2014-05-03 19:55:54: [Job] Launched Job UnrealLightmass_2014-02-17_15-34-00_983360-64bit.exe
2014-05-03 19:55:54: [Job] PID is 5672
2014-05-03 19:55:54: [Job] GUID is “D6FC5EE1-4DED45DA-F46CA391-04E6A9BD”
2014-05-03 19:55:54: Log file created: UnrealLightmass_KUBAS1129X007_1884FCA54FAE34865E3C 94A7CB05FF8F.log
2014-05-03 19:55:54: Lightmass WIN64 started on: KUBAS1129X007. Command-line: “E:\UDK\UDK-2014-02\Binaries\SwarmCache\Jobs\Job-D6FC5EE1-4DED45DA-F46CA391-04E6A9BD\UnrealLightmass.exe” D6FC5EE14DED45DAF46CA39104E6A9BD -trisperleaf 4
2014-05-03 19:55:54: Processing scene GUID: D6FC5EE14DED45DAF46CA39104E6A9BD with 4 threads
2014-05-03 19:55:54: Building static lighting…
2014-05-03 19:55:54: [Job] Found a parent connection for PID 5672
2014-05-03 19:55:54: [Job] 22448D79 → 58B6304D
2014-05-03 19:55:54: [Interface:TryOpenConnection] Local connection established
2014-05-03 19:55:54: Measured CPU frequency: 3.40 GHz
2014-05-03 19:55:54: FStaticLightingSystem started using GKDOPMaxTrisPerLeaf: 4
2014-05-03 19:55:54: Number of texture mappings: 2
2014-05-03 19:55:54: Number of vertex mappings: 0
2014-05-03 19:55:54: Number of terrain mappings: 0
2014-05-03 19:55:54: Number of fluid mappings: 0
2014-05-03 19:55:54: Number of landscape mappings: 0
2014-05-03 19:55:54: Number of SpeedTree mappings: 0
2014-05-03 19:55:54: Number of BSP mappings: 0
2014-05-03 19:55:54: Number of static mesh instance mappings: 2
2014-05-03 19:55:54: Number of SpeedTree mesh instance mappings: 0
2014-05-03 19:55:54: Reserving memory for 2 meshes, 304 vertices, 408 triangles
2014-05-03 19:55:54: Scene surface area calculated at 38.142 million units (35.682% of the estimated 106.896 million units)
2014-05-03 19:55:54: Importance volume surface area calculated at 0.393 million units (4.163% of the estimated 9.446 million units)
2014-05-03 19:55:54: Building kDOP took 0.00 seconds.
2014-05-03 19:55:54: Static lighting kDOP: 262 nodes, 132 leaves, 528 triangles, 304 vertices
2014-05-03 19:55:54: Static lighting kDOP: 22.727% wasted space in leaves
2014-05-03 19:55:54: kDopTree.Nodes : 0.0Mb
2014-05-03 19:55:54: kDopTree.SOATriangles : 0.0Mb
2014-05-03 19:55:54: kDOPTriangles : 0.0Mb
2014-05-03 19:55:54: TrianglePayloads : 0.0Mb
2014-05-03 19:55:54: MeshInfos : 0.0Mb
2014-05-03 19:55:54: Vertices : 0.0Mb
2014-05-03 19:55:54: UVs : 0.0Mb
2014-05-03 19:55:54: LightmapUVs : 0.0Mb
2014-05-03 19:55:54: Static lighting kDOP: 262 nodes, 132 leaves, 528 triangles, 304 vertices, 0.1 Mb
2014-05-03 19:55:54: Processing…
2014-05-03 19:55:54: Couldn’t gather the requested number of indirect photon paths! 0 gathered
2014-05-03 19:55:54: EmitDirectPhotons complete, 0.002 million photons emitted in 0.0 seconds
2014-05-03 19:55:54: EmitIndirectPhotons complete, 0.000 million photons emitted in 0.0 seconds
2014-05-03 19:55:54: Marking Irradiance Photons complete, 0.000 million photons marked in 0.0 seconds
2014-05-03 19:55:55: Caching Irradiance Photons complete, 0.231 million cache samples in 0.2 seconds
2014-05-03 19:55:55: Calculate Irradiance Photons complete, 0.000 million irradiance calculations in 0.0 seconds
2014-05-03 19:55:55: [Interface:SendMessage] Error: Tcp channel protocol violation: expecting preamble.
2014-05-03 19:55:55: [Job] Job has failed! Job executable didn’t exit cleanly. Exit code: 2
2014-05-03 19:55:55: [MaintainConnections] Detected dropped local connection, cleaning up (58B6304D)
2014-05-03 19:55:55: [CloseConnection] Closing connection 58B6304D using handle 58B6304D
2014-05-03 19:55:55: [CloseConnection] Connection confirmed for disconnection 58B6304D
2014-05-03 19:55:55: [UpdateTaskState]: Task Killed locally by KUBAS1129X007, counted as failure
2014-05-03 19:55:55: [UpdateTaskState]: Task Killed locally by KUBAS1129X007, counted as failure
2014-05-03 19:55:55: [CloseConnection] Connection disconnected 58B6304D
2014-05-03 19:55:55: [GetMessage] Safely returning to 58B6304D with no message
2014-05-03 19:55:56: [MaintainConnections] Local connection has closed (58B6304D)
2014-05-03 19:55:56: [MaintainConnections] Removed connection 58B6304D

and second Swarm Agent Log:

2014-05-03 19:57:43: [Connection] Detected new local connection from same process ID as an existing one, closing the old one
2014-05-03 19:57:43: [CloseConnection] Closing connection 11A42C4B using handle 11A42C4B
2014-05-03 19:57:43: [CloseConnection] Connection confirmed for disconnection 11A42C4B
2014-05-03 19:57:43: [CloseConnection] Connection disconnected 11A42C4B
2014-05-03 19:57:43: [Interface:TryOpenConnection] Local connection established
2014-05-03 19:57:43: [Job] Accepted Job 9605E310-4B028D5C-5C78C3A3-02C3F07B
2014-05-03 19:57:43: [Job] Launched Job UnrealLightmass_2014-02-17_15-34-00_983360-64bit.exe
2014-05-03 19:57:43: [Job] PID is 1856
2014-05-03 19:57:43: [Job] GUID is “9605E310-4B028D5C-5C78C3A3-02C3F07B”
2014-05-03 19:57:43: Log file created: UnrealLightmass_KUBAS1129X007_07D5E1A44D9B049D93D0 ABBF7010ED37.log
2014-05-03 19:57:43: Lightmass WIN64 started on: KUBAS1129X007. Command-line: “E:\UDK\UDK-2014-02\Binaries\SwarmCache\Jobs\Job-9605E310-4B028D5C-5C78C3A3-02C3F07B\UnrealLightmass.exe” 9605E3104B028D5C5C78C3A302C3F07B -trisperleaf 4
2014-05-03 19:57:43: Processing scene GUID: 9605E3104B028D5C5C78C3A302C3F07B with 4 threads
2014-05-03 19:57:43: Building static lighting…
2014-05-03 19:57:43: [Job] Found a parent connection for PID 1856
2014-05-03 19:57:43: [Job] 2E5A5B82 → 5D615BC8
2014-05-03 19:57:43: [Interface:TryOpenConnection] Local connection established
2014-05-03 19:57:43: Measured CPU frequency: 3.40 GHz
2014-05-03 19:57:43: FStaticLightingSystem started using GKDOPMaxTrisPerLeaf: 4
2014-05-03 19:57:43: Number of texture mappings: 2
2014-05-03 19:57:43: Number of vertex mappings: 0
2014-05-03 19:57:43: Number of terrain mappings: 0
2014-05-03 19:57:43: Number of fluid mappings: 0
2014-05-03 19:57:43: Number of landscape mappings: 0
2014-05-03 19:57:43: Number of SpeedTree mappings: 0
2014-05-03 19:57:43: Number of BSP mappings: 0
2014-05-03 19:57:43: Number of static mesh instance mappings: 2
2014-05-03 19:57:43: Number of SpeedTree mesh instance mappings: 0
2014-05-03 19:57:43: Reserving memory for 2 meshes, 304 vertices, 408 triangles
2014-05-03 19:57:43: Scene surface area calculated at 38.142 million units (35.682% of the estimated 106.896 million units)
2014-05-03 19:57:43: Importance volume surface area calculated at 0.393 million units (4.163% of the estimated 9.446 million units)
2014-05-03 19:57:43: Building kDOP took 0.00 seconds.
2014-05-03 19:57:43: Static lighting kDOP: 262 nodes, 132 leaves, 528 triangles, 304 vertices
2014-05-03 19:57:43: Static lighting kDOP: 22.727% wasted space in leaves
2014-05-03 19:57:43: kDopTree.Nodes : 0.0Mb
2014-05-03 19:57:43: kDopTree.SOATriangles : 0.0Mb
2014-05-03 19:57:43: kDOPTriangles : 0.0Mb
2014-05-03 19:57:43: TrianglePayloads : 0.0Mb
2014-05-03 19:57:43: MeshInfos : 0.0Mb
2014-05-03 19:57:43: Vertices : 0.0Mb
2014-05-03 19:57:43: UVs : 0.0Mb
2014-05-03 19:57:43: LightmapUVs : 0.0Mb
2014-05-03 19:57:43: Static lighting kDOP: 262 nodes, 132 leaves, 528 triangles, 304 vertices, 0.1 Mb
2014-05-03 19:57:43: Processing…
2014-05-03 19:57:43: [MaintainConnections] Local connection has closed (11A42C4B)
2014-05-03 19:57:43: [MaintainConnections] Removed connection 11A42C4B
2014-05-03 19:57:43: [Interface:SendMessage] Error: Tcp channel protocol violation: expecting preamble.
2014-05-03 19:57:43: [Job] Job has failed! Job executable didn’t exit cleanly. Exit code: 2
2014-05-03 19:57:44: [MaintainConnections] Detected dropped local connection, cleaning up (5D615BC8)
2014-05-03 19:57:44: [CloseConnection] Closing connection 5D615BC8 using handle 5D615BC8
2014-05-03 19:57:44: [CloseConnection] Connection confirmed for disconnection 5D615BC8
2014-05-03 19:57:44: [CloseConnection] Connection disconnected 5D615BC8
2014-05-03 19:57:44: [GetMessage] Safely returning to 5D615BC8 with no message
2014-05-03 19:57:45: [MaintainConnections] Local connection has closed (5D615BC8)
2014-05-03 19:57:45: [MaintainConnections] Removed connection 5D615BC8

Hi kubas1129,

could you probably post this into the UDK forum? UDK - Epic Games Forums Because normally this here is the Unreal Engine 4 forum. :wink:

A common reason why swarm doesn’t want to build your light is, that you have to start udk with admin rights before you build it.
Also make sure that you have a lightmass importance volume in your level :slight_smile:
Take a look at this thread: Build lighting not working/crashing - Epic Games Forums

Thanks for answer, but I try run UDK and SwarmAgent as admin, i use lightmass volume and it didn’t work. Sorry for my mistake, I did not know that this forum is about UE4 :slight_smile:

No problem :slight_smile:

I change switch render to DirectX 9 and it is working for now :smiley: (on epicgames forum I’m also kubas1129 and I started also a thread there ) Thanks again for answer :slight_smile: