Download

Light bleeding through surfaces

Hey guys, just a quick one here. The image i have attached shows light from the directional on the top right/bottom right of the ceiling and floor, and its clear that these areas should be relatively dark Is there anyway to stop this from bleeding through? The light maps on the wall, ceiling and floor are pretty high for testing purposes and the wall has a decent thickness. It is also a production build. It is only this area as directly behind that wall the direct light is coming through the window so I’m guessing that is the culprit. The wall is not overlapping the ceiling or floor but perfectly snapped so there are no overlapping pixels. Any advice on this would be great!! Cheers!

Are your walls/ceiling/floor set to static or movable?

They are all set to static

I had to put additional geometry around a corner of one of my apartment scenes out of the camera view to block the light after I tried everything else. It’s a band aid but it worked.

Yeah RI3DVIZ i have basically got a light blocker around the scene to stop light from leaking through. its not even as if its light leaks its just uniformly lit as if that wall isn’t even there.

Did you try double sided material on that mesh? Reverse the normal?

Yeah i tend to check double sided in the material when using single sided geometry, and tried so on this occasion too. The other side of the building in the rooms are in complete darkness which is perfect. I think the last thing i can try is to remove or alter the direction of the direct light and test a build just to check whether it is that or possibly the skylight. Then come up with a plan from there :confused:

I usually up my lightmap rez to 1024 and start with low settings for skylight and sun to try and figure it out. Good luck!

yeah i will pretty much do the same…thanks for your time RI3DVIZ :slight_smile: