Light Beams - SM_GodRay_Plane not scaling?

Hi All.

I am trying to replicate in my own project the light beams from the Blueprint Office example.
I have run into what feels like an infamous ‘bounds’ issue, where an object (my light beams in particular) flicker and dissappear when the camera angle is changed, even though they should be on screen.

After some research this led me to the bounds and a sort of solution - but it highlights the real problem.

I am changing my ‘Sm_GodRay_Plane’ size to a scale of 10000, which increases the bounds and suddenly I can see the light beams stay on screen, they dont flicker and they behave similar to the office blueprint ones → which tells me the mesh scaling is not happening when I render my light beams

To be honest, I cannot see where this is even being done in the blueprint office example. As such I am quite certain, my SM_GodRay_Plane is not scaling up correctly, which creates my flickering. So as soon as my object’s location is out of the view, the whole light beam dissappears.

See my pictures for the example.

Can anyone show me where in the BluePrint Office example the SM_GodRay_plane applies the light beam width and length settings? This would then correctly set the width and length of my plane and I would see it’s outline in the editor window. It is the only thing missing as everything else seems to work as expected.


After some reading, I am certainly convinced I have set up something incorrect along the way.

Surely someone has had similar problems to this when starting out or creating the light beams?

What are some reasons why my plane would be showing as entirely out of bounds pixels?

To anyone who is stuck like I was, I have posted the solution I found for scaling the mesh in the blueprint in the unreal forums : Light Beams - SM_GodRay_Plane not scaling? - Rendering - Epic Developer Community Forums