Light artifacts on foliage

Im getting these black/dark spots on my foliage. Not really sure whats causing it. The blades in direct sunlight with nothing casting any shadows on them are also getting the artifacts. Want the lighting to more smooth this looks weird and noisy.


Generally speaking.
Disable shadows for foliage and grass unless:

  1. you know what you are doing for performance.
  2. the shadows are only active In a short range.
  3. use distance field shadows.

Also, normals for objects like grass should point UP so that the engine can shade them similarly to the terrain they are on.

The normals could be the issue you have here. Since it’s shading wierd.

All that said.
I don’t really see artifacts in the screen you shared?
It looks as you would expect it to look when shadows are on and the light is where it’s at.

Debug with a more basic mesh version and no transparency.

Or turn off self shadowing maybe?

1 Like