Light artifact

I have a problem with light. Does anyone know how to decide?

Hi gerk32,

At a first glance it looks like an issue with your lightmap UVs. This is a good guide to look at for lighting issues A new, community-hosted Unreal Engine Wiki - Announcements - Epic Developer Community Forums

Could you open the static mesh in question (the floor mesh) and display the UV channel you are using for your lightmap? Also are you getting any warnings/errors after building your scene?


No errors after building.

After some additional research this issue seems to be the result of how lightmaps are baked on different threads. That means you will get a better result with a single mesh rather than many smaller modular pieces. Here is a work around that will allow you to use you modular floor pieces:

  1. Select all of your meshes that make up the floor.
  2. Open the “merge actors” tool (see screenshot for location)
  3. Make sure generate lightmap UVs is checked (should be on by default) and merge all of the selected actors
  4. Rebuild lighting

Note: Once this is done you may not be able to undo so please save a copy of your map before trying this.


, it helped, but there was one error. The collision of the combined objects is not working. The character falls through the floor.

That’s odd collision should be maintained after merging meshes. Since you are dealing with just a floor you can place a single blocking volume to get around this issue.

For testing purposes I merged two actors on my end that had collision already and wasn’t able to reproduce your issue. I would check the collision settings on the merged actor and make sure that it is set to block all.