Level visibility track is messing up Ray Trace Global Illumination in the game mode UE 4.27.2 windows

can you please help with this problem, is this a bug?
I think the level visibility is not working properly here. As you can see, it works normally, loads and unloads level when I scrub trough the sequence in the editor mode. However, as soon as I start the game simulation, it stops working properly. The scene became much more light, like it is picking up the light from the previous level, which should be hidden. Can someone explain why is this happening, and is this a bug? How should I fix this? This change in lighting will be visible in my render, so this is not working for me.
Thank you for the help

Solution = PostprocessVolumes in the sequence!

It crossed my mind that this might be a problem, so I added both postprocessing volumes to the sequence. Now when I am in the game mode, everything works as expected.
Maybe, can you please put this into documentation?


Nope! it still doesn’t work

It worked in the game sim mode, but it still messes up the render. And funny thing is, it messes only in one section, but later when I render using movie render que, and on one point, after the shot which uses different HDRI light, the rest of the footage is messed up. But for some unclear reason, it goes back to normal color, later in the sequence. I think this is a bug. Can anyone help how to report it?

As you can see in this video, the problem is still there, even though it stopped for a while when I added the postprocess volume in the sequence. The engine is not acting consistent. I don’t know how to debug this, is this a bug or what? To me it looks like a bug.

some thoughts:

the problem is clearly with the postprocess volume and when the visibility track loads a new level, this messes up the settings of the raytrace GI. (maybe even some more raytrace settings get messed up, but I didn’t notice yet)

update - the problem is definitely with the Ray Trace Global Illumination

I reported a Bug, because this should work as expected. If someone has some trick how to avoid this problem, let me know. But so far, my findings are:

  1. If you are using Ray Trace Global Illumination, set on Brute force, it will produce unpredictable results
  2. The problem shows when using the Level Visibiliti Track, in game mode
  3. It is possible to see the sequence without this problem, so it is not clear at beginning that the problem exists
  4. when going into game simulation mode, problem starts to show (like in my video)
  5. the result is - it is impossible to render that sequence, because it will mess up your lighting.

So far, in the render settings, I tried different options, warm up engine, warm up, but nothing would help.

I tried to put the post process volume in the master level, thinking, maybe this will not happen if the postprocess volume is not part of the child level, but it didn’t help

I tried adding postprocess volume in the sequence, it didn’t help