Ledge Climbing System guide

If you are referring to the the part where the character climbs then you will have to modify your animation or you have to set the play rate of the animation to a slower play rate. As its the root motion / animation controlling the speed.

Hi!
Your tutorial is amazing btw but im having an issue importing your Ledge Grab place holder, its failing to import.
it states:

Error could not import SK_Mannequin duplicate bone names found.
(SK_mannequin’) each bone mush have a unique name
Multiple roots found
Import failed.

I tried to open the FBX in 3DS Max and get rid of the roots, this allowed me to import it. However in the Third Person Animation blueprint, It cant find the ledge grab animation and it wont let me drag it in :frowning:

Knowing me its probably something stupid :wink:

P.S. im using 4.8.3

thanks for the the help!

Hey,

Make sure you’re importing the animation selecting the skeleton asset you already have for your character (the one you created the anim blueprint to) instead of leaving it to none; which will create a new skeleton just for that animation and won’t let you select it for you animbp.

Thank you that was helpful!!!

Out of curiosity, the tutorials show how to disable the movement when your on the ledge, If i wanted to shimmy along the ledge how would i go about doing this as a blueprint??

Thanks for all your help though!! :slight_smile:

thankyou that was very helpful by the way! :slight_smile: I am also having trouble with calling a function from a blueprint class, i made a function and i can call it in the animation blueprint but not in the charterer blueprint, any ideas why??

Hello,
First of all great tutorial :slight_smile:

In 4.9, I have a problem at around part 2 (and maybe after that as well). When I set the wall climb animation to root motion (ref pose) it is rotated, so that the character is crawling on the ground instead of climbing. When I set it to something else for root motion the climb animation moves the character up but not forward so it stands in the air until I move it again. What am I doing wrong? Is there a fix in a later video or is it something in 4.9 that changed, so that I might have to go back to 4.8?

Please help,
Apolyon

Hey dude can you send us a screenshot of the issue, I have it working in 4.9 so I might be able to help :slight_smile: they maybe a fix on the later videos to be fair

Here are two screenshots for the wall climb animation, where you can see the issue with the root motion rotation.
I am using the newer animations that are introduced in part 5 but the issue was there for the older ones as well.


The problem might be on my end as I am using a different character mesh and is could be rotated there (mixamo auto rigged). Maybe I did something wrong on the imports, don’t know, kinda new to UE4…

This would go fantastic in the EPIC Heroes and Villains game! :slight_smile:

Fantastic work man, always love your stuff, also thanks for the freebies on your website too, very awesome!!

Hey I wanted to start a project that includes Ledge grabbing but I can’t import your mannequin into the project. (Using 4.9) Tried importing the asset and all it says is an error. The main reason being that there are multiple bones named after the same thing or something (im not too sure myself). Hope I can get this fixed soon and start watching the tutorial vids! Any help would be appreciated!

Heres exactly what the program says:

Error, Could not import SK_Mannequin.
Duplicate bone name found (‘SK_Mannequin’). Each bone must have a unique name.
Multiple roots found
import failed.

Ok so it seems like the program is recognizing the “Grab” file as a modified version of the skeleton. I tried changing all the bone names but after I import it into unreal it crashes. Not really sure what to do at this point

Hello Crocopede,

Thanks a lot for the tutorials! I’ve followed it all (except the wall running and sliding, I don’t need those for what I’m doing) but I’m running into a weird issue.
If I jump around and climb, everything works fine, but I tried going crazy and jump > crouch to go down > jump > crouch > run around for a second > jump > crouch, etc… and after a bit, my character will end up teleporting to different areas of the climbable wall. Have you tried doing that kind of debug, and if so, any suggestion for how to fix it? I’m not a blueprint expert really, so I’m kind of lost on trying to fix this one.

If you want a video to see better what’s going on, I can get one.

Hi, I’m follow the ledge climbing tutorial and I’m running in to a problem on the first video. For some reason when I approach the ledge my character gets moved to the underside of the object instead of to the top. Here is a video displaying the issue.

Have you encountered this issue before?
I’ve been through the video a couple of times now and I don’t think I’ve missed anything.

Thanks!

  • EDIT - How Accidentally set the ledge height to Impact Normal instead of Impact Point. :stuck_out_tongue:

Hi great tutorial learned a lot. I am having odd issue hope I not only one so I can get it solved. but in regards to the move to location. my character does not move to the proper location (to hang from ledge) it instead always moves to the 0,0,0 point of the map. … not sure what to do. have done the tutorial multiple times. am using 4.8.3 of the engine.

after investigating, I found that the “wall go to location” macro always fires off 0,0,100 the first shot. after the first one it starts doing the properly but first one always wrong. so is there any way to make it not mess up right off ??

ledge climbing

hey i followed your tutorial and for some reason when you press space bar when the player is on the ledge it just goes off the wall and stands and can walk in thin air and dont know why here are the blueprints:

Ok so I have put a ton of work into this, I used this system as a base of my mechanics and I have updated and it upgraded to 4.10, I only needed to change a few things and they weren’t a big deal. It works fine with that stupid, dumb UE mannequin. I retargeted and had a few issues, but all the animations are working now with a fuse/mixamo the UE4 fbx skeleton. I had to adjust the pose which was aggravating, but that isn’t your fault… that is epic’s… Anyway everything appears to be working but the character (with the new skeletal mesh) won’t ledge grab and won’t continue up a wall if there are two placed on top of each other. The model is slightly smaller than the retardedUEman… but it is lined up exactly the same in the collision cap… . If I switch back to the retaredUEman it works fine. I have been scratching my head for two days now and I am afraid to move on to combat until that is solid…

Any idea’s I have tried it with two different skeletal meshes…

Basically it isn’t locking in anyway on the ledge. It does however allow for left and right movement on the ledge but after the ledge is gone it flys all over the place

Hello Crocopede!

I tried to apply this systems first part (first video) to the sidescroller template, but encountered with errors:

  1. If I implement ledge detection when jump, the character instead jump further from the camera
  2. Animation not played

What can I do? thanks for your help!

Hi,

I know this thread is a little old but when I saw your tutorial and the results it gave along with the free stuff, well I had to try! (sick tutorial by the way man your one really cool guy).

However,

I have a problem :frowning:

I have followed your first tutorial for the ledge grab system, I downloaded the new animations on your website rather than the old placeholder animations, I’ve imported them into UE4 and all looks good!

Here is a video though showing you my problem, I go through the graph in the video (video quality is a little bad, hopefully you can see the graph though) and right at the end of the video I show what is happening with my character. I followed the tutorial all the way through and haven’t gone away from the methods you show in the tutorial, the only difference between my project and the one in the tutorial is that I have moved the camera and attached it to the characters head socket, all values for the tracers are as they are in your video (I started with the 3rd person BP template).

[video]Dropbox - Error

If you need access to the project I can upload to Dropbox so you can see what I have done, I’ve been scratching my head over it, I don’t know whether the values for the tracers in my project need to be different, or whether there is something wrong with the animations and their states. I would really love your help debugging this though as its killing me :frowning:

Keep up the great work though bro, would love to see more tutorials and if you haven’t already got a hard drive then drop me a PM, I will gladly buy you one :smiley:

Cheers,

Dave.

I think thats possibly just because you havent disabled the inputs that allow your char to move. The standard move fwd and right axis inputs. Put a branch there with a bool called “DisableMovement” and if true do nothing if false carry on as normal.
When the hang event runs then set disablemovement to true so the player cant move. And make a button to stop hanging. I think the OP uses crouch input.