LeapMotionController failed to load


We’ve successfully built UE4 from source files, and have been able to add the LeapMotionController to the game and have our hands show up ingame. However upon quitting the editor and re-opening it again we are met with an error message:

Can’t find file for asset /Script/LeapMotioController
Failed to load /Script/LeapMotionController.LeapMotionControllerComponent Referenced by SCS_Node_2

We then have to add the LeapMotionController to the player character again, and everything will work perfectly fine until the next time we start the editor.


Not sure if bumping questions work, but this is still a big problem.

I solved this problem.
You have to follow the development document for LeapMotion to include LeapMotion headers.
Specifically this page: https://developer.leapmotion.com/documentation/unreal/unreal/Leap_Unreal_Cpp_Tutorial.html

And then you have to code in your component to your character to avoid this error.
(Just follow a MyCharacter.h and MyCharacter.cpp example if you created a FPS code template.)
I’ve attached my example for reference. Please do note that this is only my first try, so it might not be correct way to declare a UPROPERTY like I do in the file.

Thank you, I’ll try this within the next few days and return to mark the answer if it works for us.

This worked perfectly, thanks a lot Penguin.