leap motion behavior

Does anyone know if leap motion plugin is working correctly in 4.8/4.8.1? having a lot of weird unstable finger behavior, and is not the sensor or the usb or anything else…it just happens with unreal engine.
Thanks in advance.

Just in case someone needs an answer on this, it seems its a bug and can be solved with this:

I am trying to make it work on 4.9, and the tracking is stable, however, I am having trouble attaching the hands to the player: they appear above it (could be fixed easily), but also move away from the player as I start walking in the level.
I will try on 4.7+plugin tonight.

Suisso if your intention is using leap motion with an hmd on 4.9 do not bother about it, vr preview still not working (at least for me) so i would recommend you to use Oculus UE version.

The instability for fingers is due to the collision preset on the bones, as in they collide and there is not enough space. Make a new actor for them or modify the plugin source ones to have a custom setup that does not collide with itself. Haven’t igured out how not to make them not freak out when for example grabbing other objects. Short of using a skeletal model that is.

Malcriado, thanks for the tip. Yes I am trying to make a demo for the oculus DK2, with leap hands and unreal (any version).
It’s proving more tricky than expected. I managed to get the oculus working with 4.9 but at the cost of buidling the whole level and playing it as an .exe (alt+enter). I don’t think the vr preview is working indeed. I will look for the oculus UE version as suggested. I see a lot of demo making use of UE and leap motion (weightless being the best). I just can’t figure out to get those 2 things working right now. I’m very, very new to real-time so I’ll keep digging. Will keep you posted if I find one way to get those 3 things working together.

Suisso did you find a way to get them attached to player to walk with them im having the Exact same issue on 4.9 but im not using any VR. i dont know what to do they keep moving away from player at 2x the speed

[QUOTE=suisso;344381Will keep you posted if I find one way to get those 3 things working together.[/QUOTE]

How are things going?? I have a Presentation next week using leap motion and unreal with the oculus i made in 4.8…stupidly I automatically assumed VR worked in 4.8 since it worked fine for me in 4.7. Now Im stuck. Do I rebuild the project entirely again in 4.7? or try for 4.9? So i’m curious to know if you made any progress before I start rebuilding in 4.7…sad day

I’m using UE4.8.3 with Rift DK2 and VR preview is working fine for me. Using Oculus runtime 0.6.01. I did have to use older drivers to get it stable though. Nvidia drivers 350.12 or something like that. I’m also using Leap Motion (with the unofficial plugin, as the official one is reported to be buggy with UE4.8) and it’s working ok. I’ll test it with 4.9 P2 on monday when I get back to work, and see if that works as it should.

Hello all, sorry for the late answer. I have at last managed to get it to work. In a nutshell:

Using the official build of UE 4.8.3
Using the unofficial plugin for leap (Getnamo)
and rolling back to the leap motion driver to 2.2.6

Then following Getnamo’s tutorial here:

However I got stuck with my third person character still being used as my player. After a bit of fiddling, it turns out that deleting the original third person character was all I was missing. Actually, you can see it in Getnamo’s tutorial at 3:19, but it really is a flash.m It makes perfect sense actually. I would have thought that changing the game mode would take care of it, leaving a “dead” skeleton in the scene, but it’s not the case, and it still tries to use it until you delete it for good.

This solved my problem.

As a side note, the arms don’t follow your view in normal preview mode, but it VR preview mode, they are attached to your headset.

I hope this helps!