Download

Leap motion 4.11 position/orientation of hands (ORION)

Just wondered if anyone had successfully implemented the ORION build of leap motion into a VR UE4 project yet?

I have tried adding the Leap controller to my first person BP using the official plugin and the position of the hands is way off and
sort of flipped upside down and a mile away from the first person origin. I have HMD mode enabled and ticking
‘Attach to camera’ seems to make it worse.

I spent a long time (too long!) trying to adjust the position and rotation of the controller and almost got the hands close to the right place
in front of the player via trial and error but then as soon as I move the character the hands drift away in the wrong direction.

Anyone found a fix for this or has successfully implemented it into a 4.11 project? I know it is technically a preview build but
it works fine in a nonVR/first person project in 4.11

I have the LeapController as a component inside my character/1st person blueprint.

I got the Leap Motion to work using the Orion Update. I’m using getnamo’s plugin and I’ve made some very slight alterations to it. There were a few gotchas between the old update and the new one. Here’s what I ran into:

-The Leap Motion device can now be “upside down”. It doesn’t auto-correct its up direction like it did in the old driver, so you need to have the USB output coming out of the left side when its mounted to your HMD.
-Within your LeapAnimBodyConnector blueprint, you have to add a node called “Leap Facing Mode is HMD” and wire in the output from the node “Is Head Mounted Display Enabled”.

It took a few hours to figure out what was going on. Other than this, I had no issues updating my project to the Orion drivers.

Great, thanks for that, will give it a go. The Orion update is amazing and cant wait to get it working!

I am still figure things out. Could you be more specific on what I need to do here? I am in the “LeapAnimBodyConnector” blueprint, but I am not sure how to proceed as you described. I have a “Get Leap Facing Mode HMD” and “Set Leap Facing Mode HMD” option. I tried some various things, but my hands are still upside down/backwards in game.

Thanks in advance.

I am experiencing this as well, and spent way to much time last night trying to fix and debug this issue. I posted on the Leap Motion forum last night and I will upodate you all if I figure it out/get an answer. Good luck.

So I finally got a chance to start debugging this and maybe with my findings you can do soomething further. I found that if I switch the player to the LeapEcho Hands I am able to adjust there starting position and rotation in the viewport then they are correctly rendered on the screen. the xyz coords are as follows

rotation
x = 240
y = 0
z = 100
(on each hand mesh)

location
x = 50
y = 0
z = 75

this allows them to be properly shown in the game. I will report back if I am able to do this with the rigged body as well although I don;t believe i will be able to.

Glad to see that you made some progress.

I apologize for my noobness, but how/where did you do that?

If your hands are upside down after the Orion Update, you have to flip the Leap Motion device. Take it out of the face mount, unplug it, turn it around, and plug it back in.

If you are using the UE4 plugin created by Getnamo, you should look for your “LeapAnimBodyConnector” blueprint. Open it up. Within the “Event Begin Play”, you want to SET “Leap Facing Mode is HMD” to “true”, or just wire in the output value from “Is Head Mounted Display Enabled”

This does not fix the issue, for some reason the leap motion is linking the left hand to the right arm and the left arm to the right hand

Search LeapEchoCollisionCharacter and you will find the hands, they come with getnamo’s plugin

What version of UE4 are you using? I tried to integrate it into 4.11 and I get a lot of error messages and the project wont start

I’m still using 4.9.2