Download

Layered Material- Blend Glass With Opaque Material

This is the first time I’ve tried using Layered Materials and the result I’m trying to achieve is a gradient from glass to an opaque gray based on a png texture. The glass material is just the nodes from the non-RT glass master material from the Automotive Materials pack and the gray is just a base color at the moment. As you can see from the images, the materials seem to be blending correctly, but the glass material is not rendering correctly. It almost looks as if it is being rendered as an opaque material instead of a translucent material. I’m not sure how blend modes are handled in layered materials or if ones other than opaque are even compatible, but I couldn’t find anywhere to specify the blend mode if that is in fact the issue. If anyone has any ideas what the issue is, or if there is a better way to achieve the result I’m going for, please let me know. Thanks for the help.

If it helps at all here is some additional info and troubleshooting I’ve done:

The gray material is the background material and the glass is set to layer 1.
Ray-tracing is enabled for everything but translucency in the screenshot I included, but it doesn’t work with it disabled either.
I’ve tried using the RT version of the automotive glass as well as a super basic glass material in place of the current one, but neither made a difference.
I’ve tried making the material two-sided, which didn’t help
I re-imported the mesh with some thickness, but that didn’t make a difference either. There is no thickness on the version shown in the screenshot.

Let me know if there is any other info you might need.

1 Like