Launcher Update Stuck on Downloading

Hello , i just compile and run Editor.exe and when click on the “Marketplace” it shows me "Updating Unreal Engine Launcher

and everytime it shows me 70~85 MB left , and stuck on 80~81% and nothing happened !!!
is that normal !?
because my connection does not have any errors !

[Edit - updating answer to have all of information contained in thread]

Hi Viper, sorry for inconvenience…

real issue is that we have a global timeout that is set too agressively for slower connections, if 1 file takes longer than 3 minutes to download it times out and will attempt to retry it. Most of our data is chunked, and is usually under 1MB so that’s ok even if you have a really slow connection, however at this point in download it’s attempting to download a 50MB file. fix will be in a future version of launcher, but for now, you can edit DefaultEngine.ini to increase timeout value. You can find it here: "c:\program files\unreal engine\launcher\engine\programs\noredist\unrealenginelauncher\config" and add following section to end:


If you have any additional problems after changing this setting, you can enable extra logging so we can help debug issue. Add following section to same ini file you changed before. You can up (Logs are in c:\users\YOUR_USER\appdata\local\unrealenginelauncher\saved\logs) and post here. Thanks!



unfortunately it did not work :frowning: :frowning:

here is latest logs link text

Same problem here :frowning:


I tried it and it’s still not working! :frowning:

Here’s my log:

How can you accept this as an answer when both of us said that it’s not working? :expressionless:

Hmm, your still getting a bunch of timeouts even after increasing time, can you go back into defaultengine ini and try increasing numbers a bit more?


Really !?!?!? Answered !?!? No its not answered ! problem exist and nothing happened !
please saw log files and tell me whats wrong :slight_smile:

i know ■■■■ always happened , even in big , adulated high-end tech Companies and software’s , but support team gonna make through these kinda problems ! its whether ours or Your’s problem , so please lead us to make it , as one word we need some UNREAL Help :smiley: !

thanks UNREAL

It’s marked as an answer for now so that it gets pushed to top, for easier reference by our developers. Sorry for any confusion.

then thanks for it :slight_smile:

Nothing happened again ! :frowning:
its just stuck on 81% and told me 70MB remaining


Thanks Viper, can you post logs on here from this run? Can you try upping timeout values again? Try:

i try this :

and here is 2 new logs with new settings :frowning:

Thanks for trying that Viper, we think we might have a new QFE for you to try soon, will update this thread as soon as it’s available.


Ok then i will wait for this Quick Fix Eng. , and thanks so much Carlos , and thanks to UNREAL

Ok Viper, it’s ready! You’ll have to do following:

  1. Download QFE from here:

  2. Replace EXE from the “Unreal Engine\Launcher\Engine\Binaries\Win64” Folder with one in the .

  3. Add “-CPLabel=QFE2” to command line of your shortcut.

I have same problem. I tried this QFE and everything is ok Now. Thanks for your help !

YEEESSSSSSSSSSSS !!! Thanks Thanks ! its launched !
i see market place !!! thanks so much !

This fix just worked for me as well, so thanks a lot for support :slight_smile:

Do you have Quick Fix for Mac? I have same problem but installing Unreal Engine not Launcher.