Launcher update stop at 80 percent

Hi. There is a thread here:

about many people having a problem with the Unreal Engine launcher updating to 80%, then stopping, resulting in them not being able to open the launcher interface. I have posted there, but that post feels crowded and all of the solutions specified there have been tried by me and others, with no or only temporary success. Which is why I am creating this new thread.

Epic, my launcher updates to 80%, then stops. I have applied the QFEs, and my launcher did update successfully after that. But then after the successful update, I removed the command-line arguments, and if I launch it again, it updates again, and again stops at 80%.

I was expecting the the QFE would, once having run/updated completely, fix the issue. But this is not the case.

Please let us know what is the status of this issue? Specifically:

  1. Is there a QFE that fixes the problem permanently?
  2. If so, do we have to apply it and the command-line arguments, and never change the command-line arguments again?
  3. If so, since the command-line arguments specifies a QFE to use, would this not mean that any ‘regular’ updates will now not be detected/applied by our updater, since we would be running in a specific QFE ‘mode’?

Please let us know what the status is with this issue. Maybe I have just not understood, perhaps there is a solution - please tell me. Otherwise, please let me know if it is still a known issue that you are working on. I am just concerned that the previously mentioned thread seems to have been abandoned by Unreal support, even though this seems to still be a problem. And please, correct me if I am wrong. We would just like some feedback, please, as it is very frustrating for a small download to just stop like that, with no apparent solution.

Thanks,
Marius.

Did you try the solution with manually modifying the DefaultEngine.ini to include the following?

[HTTP] 
HttpTimeout=600
HttpConnectionTimeout=180 
HttpReceiveTimeout=200 
HttpSendTimeout=200

This has had the greatest success with the majority of users. Please be aware that even after this update, the download will appear to stall for a few minutes, but please be patient and it should complete.

Hi Stephen. I have fiddled with the settings under [HTTP], but when I am at home after work today I will give these specific values a try. Thank you, I will let you know if that works for me.

I know these values haven’t helped me and I had to use the QFE, which without the command argument, I don’t think is a permanent fix. However, I have noticed there has been a large update recently, but I have yet to download it yet so not sure if it holds a fix within that or not?

Hi Stephen. Unfortunately this did not fix the problem for me either. As soon as my download reaches 80%, the UI reports that the download rate is 0 B/s. Then it stays there. Same as before, I am sorry to say.

Thanks for the help but this is not fixed for me yet. I hope you have more suggestions!
Marius.

Just leave it for a few minutes and it will eventually complete.

I’m having the same problem… Can you guys give me a new alternative?

I cant change my timeout because I dont have the lines!

here is my file:

[Configuration]
BasedOn=..\Engine\Config\BaseEngine.ini

[OnlineSubsystem]
DefaultPlatformService=MCP

[OnlineSubsystemMcp]
bEnabled=true

[OnlineSubsystemMcp.OnlineIdentityMcp]
bAllowMultiLogin=true
VerifyTokenInterval=400.0

Where can I change the timeout limit? PLEASE HELP. I really need to solve this asap…

Double the numbers in Stephen’s post and give it a couple of minutes. I had the same problem yesterday and increasing the timeout value helped.

You just have to copy and paste these lines at the end of your .ini
Personally, I set these values to a much higher level, that’s the only way I could finish the download, as my connection was absolutely slow.

[Quick Resume of what worked for me:

QFE CL2031728, no command added to the shortcut,

(Link to the QFE, which should replace your UnrealEngineLauncher: http://cdn.unrealengine.com/qfe/UnrealEngineLauncher-QFE-FromCL2031728.zip )

Values set in DefaultEngine.ini

[HTTP]

HttpTimeout=3600

HttpConnectionTimeout=1440

HttpReceiveTimeout=1600

HttpSendTimeout=1600]

(From my answer to this thread: [Bug] Subscribe instead of Start-Button - Getting Started - Unreal Engine Forums)

(My values may be insanely too high, I don’t know anything about it, it was purely experimental)

You can also add this lines to your .ini

[Core.Log]

LogHttp=log

LogOnline=verbose

This will give more detailed informations in your log, and, as much as I understand it, the elapsed time for each chunk being downloaded, just to see if your timeout values are set high enough

Hi again everyone.

Yesterday I doubled the numbers in Stephen’s post and left the launcher to download. I eventually went to sleep, and woke up, and 9 hours after starting to wait, this morning, it was still at 81%. Then I applied QFE CL2031728 as suggested by wDesoto and changed my ini file settings to what he suggested, and waited for an hour. I eventually had to come to work and I left it, but it was still at 81% when I left it.

While I was depressedly (is that a word?) looking at the 0 B/s download screen this morning, after it had been there for many hours, I checked my downloads by starting Steam, and let it update one of my games. Steam happily downloaded 300+MB while the 70 or so Megs left for Unreal Launcher to download did not move at all.

I need someone from Unreal to officially write a response here, just let us who are struggling so much with a stupid 70MB download know what is going on - do you recognize there is still a problem, and are you working on a solution. Please I do not want to be difficult, I LOVE Unreal and the Unreal Engine, but quite frankly this is getting ridiculous. That there is a bug is OK - I am a software engineer myself, and if anyone know that bugs are a reality of life it is me. But what is really bothering me now is that I am struggling, many people are, we are posting here, and it seems as though Epic is not communicating to us anymore about this issue. I do not even know if you are still looking into this problem.

So please help. we are after all paying money for this. At least tell us what the status of this issue is.

Indeed, even if I get past the update, i’m still stuck on the launcher, which tries either to sync my account, or don’t launch any kind of editor download, showing me the infamous “Subscribe” button. All this issues are neither “Resolved” nor should be closed. Being unable to go beyong these bugs is hugely frustrating as it takes many hours to test each kind of hypothetical solution found on the answerhub (as my own one for you marius!)

Some support from Epic is really needed here,
Thanks

In my case it seems to be a timeout issue again, as the values in the ini were restored after the update. The launcher may fail to receive the manifest for UE4 build, and sometimes for the content in the marketplace, some being labeled as “coming soon” (i am not talking of the ones in the “preview” section, Iunderstand these ones are really “coming soon” :slight_smile: ) and others being ready to download, it’s completely random at every launcher opening

Here is an excerpt of my log for the build:

[2014.04.03-11.55.35:194][ 0]

LogHttp:Warning: Timeout processing Http request.

00000000098BCB00 url=http://download.epicgames.com/Builds/Rocket/Automated/Engine/CloudDir/UE_4.04.0.2-2034640+++depot+UE4-Releases+4.0-Windows.manifest

Now I changed my timeout values and i’m waiting for it to “sync my account”…

Also, a new version of the installer is out, maybe it could solve this update issue, but it’s the version i got after finishing the update, so it may not resolve the issues past the update

I am trying to save the manifest linked above with firefox (i don’t know why actually) and it’s hugely slooow! In five minutes only 9 ko have been downloaded! The launcher may not be the only culprit.
(edit: the download even failed, actually)

(I must mention I begin to feel a bit stupid posting informations about somethings I don’t understand at all, but It’s driving me so mad, as Marius said, I love Unreal Engine, and it’s too hard to wait in the grim place of timeouts and launchers while the Black Magik of UE4 is available)

I am busy downloading the version 4.0.2 source and optional and required components. I will extract these and build everything tonight, maybe that helps. If not I will run the new version of the installer. It is now 9 AM in North Carolina, where Epic is located. Perhaps the support people were asleep. Fair enough. I will give them 8 hours to reply, to tell us what the status is of this bug. After that, I don’'t know. Perhaps there is some way to escalate this. It is ridiculous and my time is being wasted because their updater can not download a few megabytes, and moreover we are getting no support from Epic. And yes, I am really sorry to post this, and I do not want to sound like a complaining idiot. I hate complainers.

But really Epic, help us? Tell us what you want? Do you want my logs? I will gladly send it. Just let us know what is going on with this issue. This bug has been reported on 21 March already, at least.

I have tried it, it is just 8MB big and downloads with no problem (at least from my work). If you want I could probably send it to you by e-mail (would that be allowed Epic?).

I like your comment - indeed, the Black Magik of Unreal 4 is so close, but this launcher issue… very frustrating.

I am making another try with the command added to the shortcut, as it may solve my manifest issue, so another update is required… Guess I’ll just wait a bit and take a breath outside :slight_smile: