Download

Launcher + Marketplace downloader for Linux

Hello,
I’m using Linux (Ubuntu 17.10 version), so I had some problems with marketplace, wasn’t able to download assets, since Epic Games Launcher is working only on Windows/MAC.
So I’ve decided to look for some other ways, how to download it.
I have found this project: GitHub - Allar/ue4-mp-downloader: Shell utility to download owned assets from the UE4 marketplace.
Researched it and thought to make one, with GUI and couple more implementations, so I’ve somehow managed to make it.
It may not work 100%, sometimes downloads stops at item manifest, but stopping the download and starting again helps!
Some photos for it:

So in end, I thought maybe there will be people, who will find some use of it and decided to share this system.

I have tested it only on my pc (Ubuntu 17.10 + Java 1.8). So I’m not responsible, if it will not work, you have full source, so you are free to fix / rebuild it yourself.

This is the link to the github: GitHub - Erlandys/UE4LinuxLauncher

Compiled version with shell script to start is in github repository “Compiled” folder.

Feel free to comment and have a good use of it!

Yay, more Linux love!

Unfortunately, I don’t run Linux on this machine at the moment due to my CPU lacking the necessary tech for proper virtualisation.
That said, all the other machines in the family do, so…

In any case, thank you!

@Erlandys

Nice one, cheers dude! Will you be able to keep maintaining this?
(Seems Epic make changes to the Marketplace setup over time).

I will try my best, but can’t promise that I will be 100% up to date and that I will be always able to update it.
I’m using it myself, so it’s originally in need to have it working for myself, so when something will appear, I will try to fix it.
Also, full source is on GIT, so everyone can contribute changes or fixes to git all the time!
PS. Thanks for you words! :slight_smile:

Very awesome, Linux getting some much deserved love.
Btw you should pick a license for your github project https://choosealicense.com/

Hi.
Thank you so much.
I’m on ubuntu16.04. Everything works well with the compiled one you provided.
Awesome.

This is great, thanks!

Hey thanks for this! Unfortunately, it’s not letting me login. Keeps telling me I’ve got the credentials wrong.

I am trying to use UE4LinuxLauncher-master but it asks for username & password in Login but it says credentials are invalid but this also happens with UE4 downloader

Hello,
problem with credentials was fixed today, check github.
Currently working on implementation for two-factor-auh.

Thanks a bunch for this. Not a huge fan of Java but this is a really good tool. PLEASE maintain it! I know Epic likes alienating the Linux community in every way possible.

Just tried this today. Lets me log in and see the marketplace, but it doesn’t show me anything in Owned Assets.

Hi, it’s weird.
It showed “part of my asset downloaded” before.
But not what I bought, which is kind of terrifying…
Anyone experience this as well?

Great job! Works fine from source on Arch Linux (after activating 2-factor-authentication).

Hi! Just found this tool and it seems great, but I’m not able to login, I have “Error: #1008”, what does it mean?

I remember having had that issue, but I think it gets away once you enable Two-Factor Authentication in your Epic account security page.

Thank you for your suggestion! It probably depends on that, since I haven’t yet activated 2-factor authentication.

EDIT: Yes! Enabled Two-Factor Authentication and now it works! Well I had to follow also the suggestion here (UE4Editor.version path changed in 4.22 · Issue #11 · Erlandys/UE4LinuxLauncher · GitHub) to make it recognize Engine 4.22.

First of all, I would like thank you for making this. It will be a huge help to a lot of UE4 users. Btw I just had an issue: my Launch UE4 button is disabled. It basically didn’t even identify the version. Even tho I have it installed. Any idea why this happened? I tried changing the directory. To the folder where the Editor is and updated it. It didn’t work. Can you please help me out? I will greatly appreciate it.

Hello,
I had stuff going with university, but it finally ended.
I have fixed problems with authentication, when not using Two-Factor Authentication (problem with #1008 code).
Also currently working on fix for 4.22 version, to work properly. Track github page, I will do more updates.

Sincerely,
Erlandas

Hello, I have a problem Marketplace downloader can’t se my assets