Launcher Crashing on startup - Serialization Error : Action Needed


I’m currently having an odd problem with my launcher in that it is crashing upon startup. First of all today I actually managed to open up the launcher but then I kept getting an error window pop up when trying to load one of my version installs saying ‘Serialization Error: Action Needed, corrupt data found, please verify your installation.’

I closed the launcher and tried to reopen it but then got the same error, so now I can’t use it at all. I have tried reinstalling the launcher completely but I keep getting the same problem. Here is my most recent crash log:

Crash Log

Any help on what might be going on would be greatly appreciated.

Hi JBroderick,

I’m sorry that you are having an issue with the Epic Games Launcher. In order for us to offer the best support, we have recently modified the process for how Epic Games can help troubleshoot your Launcher issue. Please visit for technical support, here you can find information and solutions for common issues, as well as a contact form if you still need additional assistance. Thanks!

I found a fix to this:

Navigate to the following:


And delete the 4.12 folder (or whatever engine version you’re having an issue with).

It’s as simple as that. The next time you launch 4.12, it will take slightly longer as it’s rebuilding some data, but it should work.

In my case this was caused by the C:/Users//AppData/Local/Temp/ecache.bin file. The exact file causing the problem can be found by appending a -debuglogging argument to the launcher shortcut and then searching for the error at the end of the resulting log in C:/Users//AppData/Local/EpicGamesLauncher/Saved/Logs. Since it was a temp file, just deleting it helped to start the launcher successfully.

So I found out the answer was simple. Turns out if you ever installed Unreal and you later have your environment Temp & TMP paths changed at all(probably to free up space on your C:), then the launcher will fail. You can test this by making another user, and if the launcher works on that account and not yours then you can be sure it the environment variable. Just go to your system settings and set them both back to:

After a restart that should fix the problem.