Download

Launch on Quest 2 not working

Hi I’m working on my project for Quest 2, and I’m experiencing problems launching it on the device. It’s worked at a different stage of development as recently as two weeks ago.

It s running fine using VR preview over the Link, but launching it as an app is the problem. The level loads, everything looks good, but the controllers have no function. I can see the controllers, they track and move; BUT no teleport, can’t grab etc, buttons don’t work (except the ‘o’ menu to quit the app button)…

Any thoughts?

I’m still experiencing this issue, has really no one experienced anything like this? No idea how to fix it.

I’ve just tied creating a brand new VR template project and launching that onto the quest, but the controllers and teleporting are now not working with that either. So I’m thinking it isn’t necessarily project specific setting, but perhaps a global setting in UE4 which carries over from project to project when they are built for the quest platform?

This is a total guess though, and no idea which setting might cause this.

What plugin are you using? If using openxr, try disabling and enable the oculus plugin.

Thanks for the reply. OpenXR was enabled, so I tried disabling these plugins, it grumbled that Quest plugins needed them to work, anyway I tried disabling them all the same. Hasn’t worked so I’ve set them back as they were before.

In project launcher quest 2 is set to default, under variant, is that correct? Options seems to be Android, android_ASTC, Android_MULTI etc…

When you disabled them did you make sure the normal oculus plugin was enabled?

you should use ASTC but i dont think thats causing your issue.

Right, Fantastic, I’ve tried it again, Oculus OpenXR now disabled and that seems to have fixed the problem. Many many thanks

Curiously though everything seems to be lit very differently now? Does Oculus OpenXR have some influence on the scene lighting?

Also, I’ve noticed that since doing this my controllers have changed from white to black? What’s the reason behind this. While I have my functionality back, I’m not sure that this is operating as it should.

Im not certain on the lighting. For the controllers, i normally use hand meshes that i have so im not sure about that since i dont normally use the controller models.

No worries, you’ve been enormously helpful anyway

There are different API’s being used between OculusVR, and OpenXR. When you’re using OculusVR, the Device Visualization on the MotionController component is choosing its mesh from a different library than when you’re using OpenXR.

I’ve never come across this issue before using the VR Template in 4.27. Do you have any more information? How are you launching? Packaging log? - etc. Thanks!

Thanks for the reply Victor, so today I have tried creating a new VR Template from scratch, and launching and it is working as expected. I think before my VR Template did have a little bit of my of code so it wasn’t a fair representation of completely clean slate.

Anyway, since then I’ve imported all my blueprints back into this new VR template and the app is now launching fine again, correct colour controllers and everything. So I am not sure what could be causing the issue on the old project, as all the model/BP data is the same. I can only conclude that it is a specific project setting which I must have changed unwittingly which is causing the launch failure.

With the old project, my only fix to get the project to launch was when Oculus OpenXR was disabled. But with the new VR Template as the starting point it’s working fine now with this setting enabled again.

1 Like

I’m late to the thread. I had the exact same problem in the VR Template (UR 4.27.2).

It turns out the Oculus CV1 was still showing as an active device in my Oculus settings (despite not being connected). I removed the Oculus CV1 in the Oculus settings and at that point the VR template worked flawlessly.

1 Like

where is this Oculus CV1 setting? that you’re talking about please?

Open up the oculus app, click on Devices, click the arrow to the right of the CV1, scroll down, and click remove. I’ve already removed mine.

Please disregard that the attached screenshots contain the Quest 2. If you ever had the CV1 installed on your PC and never removed it then the CV1 will still be listed as a device. Prior to me removing the CV1 it showed up under my quest 2. I had to scroll down to see it.